Sign in to follow this  
Guest cbuchner1

Beta 4 just posted

Recommended Posts

I have just posted Beta 4. If you're lucky, it will make things a bit faster for you.Just please make sure you either check or uncheck the option, depending on whether this is true or not: "check this if you have Flight Simulator X Service Pack 1 installed". Uncheck if you're running the RTM version of FSX, please.Users with FlightSimulator 2004 may also want to try this Beta 4 release as it adds compatibility for this dated (but classic) Flight Simulator version. I think there are still more active FS 2004 users out there than there are FSX users (edit: awkward typo corrected) Optionally Tileproxy will also hook into FS 2004's scenery.cfg file. This works best if both FS2004 and FSX are installed in their default location, which is the Program FilesMicrosoft Games folder. Then they can share the TileProxy World folder which resides in Microsoft Games.The new Tileproxy version doesn't require FSX to be present to allow the installation. Simconnect.dll will always be deployed on your machine, therefore allowing Tileproxy to run even without an FSX present on your machine. Of course it won't be using simconnect to interface with FS9 - it uses FDSConnect.dll (a freeware from flightdecksoftware.com)As always with any Beta release, you're the crash test dummies ;)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Grabbin' it now and THANKS! For this, I have no problem being strapped into the vehicle and smashin' against the wall as a crash test dummy!

Share this post


Link to post
Share on other sites

Christian, should we uninstall Beta 3 before installing 4?Also, will Beta 4 work better with or without SP1?thanks

Share this post


Link to post
Share on other sites

I have run into the "simconnect.dll not found" error referred to in another thread.I do not have FSX SP1 installed (just have FSX RTM) and left that option unchecked.I installed on top of Beta 3.I found a version of SimConnect.dll in WindowsWinSxS... Its reported version is "10.0.60905.0" and is dated 29/10/2006 8:36AM and is 37KIf I copy this into TileProxy directory, TP then reports "attempt to load C runtime library incorrectly"Not sure if any of this info helps ;)

Share this post


Link to post
Share on other sites

I just posted a fixed installer for Beta 4 on sourceforge.Ouch! About the C runtime problem... I can only hope the new installer fixed that also. I haven't had this problem before.

Share this post


Link to post
Share on other sites

Install-over (or "upgrade installation") is always supported by Tileproxy. It will keep your existing config file (as far as possible).Performance with SP1 is different from machine to machine. If you get the blurries without TileProxy you will DEFINITELY also have them in TileProxy. And the blurries seem to be a very common problem with the SP1.

Share this post


Link to post
Share on other sites

Hi Christian,As ever, thanks for all your efforts, they are greatly appreciated :)Can I ask you to post a list of the changes made to FSX.cfg?I ask because each time I have to revert back to my own FSX.cfg as I'm afraid I see ugly blurries around my a/c and the stutters/surges* are far worse.(*)'Surges' = periodic side-to-side twitching of the whole scenery window content behind the a/c as viewed mainly, but not exclusively, in SPOT view.Generally what I have to do is revert back to my original file or delete/reset:TEXTURE_BANDWIDTH_MULT : reset from 400 to 40FIBER_FRAME_TIME_FRACTION=0.40 : deletedMipBias=6 : deleted and set in driver using ATT to 'High Quality' (I suspect this setting benefits nVidia GPUs more than ATI)Anisotropic=1 : deleted and 'Trilinear' chosen in sim, AF=16 in ATTPoolSize=5000000 : deleted LOD_RADIUS : reset from 2.5 to 3.5 (medium)Cheers!MikeASRock 939Dual-SATA2, AMD Athlon 64X2 4800+ (2400MHz)(Toledo), 2GB Crucial PC3200 DDR400 Ram 3-3-3-8 (2T)(Dual Channel), (PCI-E)Sapphire ATI Radeon X1950 Pro 512MB (Catalyst 7.1 WHQL), SB Audigy2 ZS Platinum (Drivers version 5.12.0001.1196 WHQL), Windows XP Home Edition (SP2), DirectX 9.0c (with 04/2007 update)

Share this post


Link to post
Share on other sites

Thanks Christian. Much appreciated as always.Test Dummy BasicBob

Share this post


Link to post
Share on other sites

The user manual lists all changes that are made to fsx.cfgDuring TileProxy istallation you can uncheck the option "modify fsx.cfg for good performance with TileProxy" to keep your fsx.cfg untouched

Share this post


Link to post
Share on other sites

Hi Christian,Thanks for posting thisI've done a fresh install of Beta 4, installed FDSconnect.dll into modules, and configured a source for imagesWhen FS starts, Tileproxy confirms it has connected to FS9, but then nothingWhen I start a flight, no errors, just standard sceneryThanks for any hintsEGLD

Share this post


Link to post
Share on other sites

Now that is odd, the installer automatically copies FDSconnect.dll into the FS9 modules folderTo do this, it relies on the "Exe Path" registry key inside the Flight Simulator 9.0 registry branch.The full key name is HKEY_LOCAL_MACHINESOFTWAREMicrosoftMicrosoft Gamesflight simulator9.0Under this key the String "EXE Path" should indicate the folder in which your fs9.exe resides.The TileProxy installer relies on this very key to find the scenery.cfg file of FS9. It will add about 100 world scenery areas to this file.Maybe an FSX install/deinstall botched that FS9 registry key for you? There are automated repair tools by FS9 addon vendors available to fix the key, or you can add it manually with RegEdit.

Share this post


Link to post
Share on other sites

No thanks Christain....Beta 3 works so dam well Im afraid to mess with it....You saved FSX!!!!Jareth

Share this post


Link to post
Share on other sites

Beta4 works fine with SP1 !Thanks a lot !:-jumpy

Share this post


Link to post
Share on other sites

Hi ChristianBeta 4 is working great on unpatched FSX, I only have a 512k connection but the Tiles are getting downloaded much quicker with Beta 4 than with previous versions, especially when using Google.Great stuff thanks again for all the hard workJohn

Share this post


Link to post
Share on other sites

Hi Christian,Yes, that was it! The key didn't exist, now all is working fine, and it looks great, though nowhere near as good as FSX obviously....Thanks once againEGLD

Share this post


Link to post
Share on other sites

Never mind...after reading this..I punted and down loaded beta 4...no problem....I am a layman..so I did not mess with the config file (again) at all...just downloaded and reboated...did not even uninstall 3...all seems fine...sorry Christain if that is bad advise...but those like me who were afraid to update...it seems it can be done easily....Thanks..jareth

Share this post


Link to post
Share on other sites

I've been trying to find an answer on the forums to this issue, but am stuck - sorry if I've missed something obvious.When I first ran TP I got "missing filter" messages. I copied some files into Windows/system32, and that let me make progress. I'm running on Vista, SP1, btw.I now get this, using Run as Administrator:http://forums.avsim.net/user_files/173112.jpgAny ideas what's up?

Share this post


Link to post
Share on other sites

It's supposed to do an automated "right click installation" of the tileproxy.inf file (which creates some registry entries and copies tileproxy.sys to C:windowssystem32)Do that manually, right click the inf file and hit install.Let me know if the filter then loads.

Share this post


Link to post
Share on other sites

Thanks for such a swift response - this worked a treat.Sadly I now have no textures loading, but am following the other thread that's running on this issue, and will try the tweaks you've suggested in there. I have had blurries since SP1 (not RTM) on my core dua 6600 8800GTS, so I am realistic about what to expect!Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this