Archived

This topic is now archived and is closed to further replies.

moggel

Texture Problems In Dx10?

Recommended Posts

I've just recently started to fly FSX (finally) and yesterday I deactivated the default AI and replaced it with World of AI. I then noticed that some AI models appeared had no liveries; the planes where plain white! Having roamed the Internet for information I've seen several posts talking about this being a Direct X 10 preview issue so I tried deactivating DX10 and, indeed, the liveries where all there again!Now, can someone with the tech know-how confirm DX10 can't handle (some) textures and please explain what's going on? Also, is there something one can do to fix it? I've fallen in love with the "bloom effect" in DX10 you see and I'd hate to have to choose between decent AI and bloom. The bloom effect in DX9 doesn't look too good and is also very taxing on the system, whereas the same effect in DX10 is beautiful and seems to have very little impact on the frame rate.Cheers/Jonas

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Jonas,The AI planes that are "white" are DX9 models. If a model is not DX10 compliant it will not display properly. It has nothing to do with it being a DX10 Preview issue (there are however issues with DX10 Preview). Quite simply the models need to built from the ground up utilizing the FSX SDK in order to be DX10 compliant and disply properly with DX10 preview enabled.

Share this post


Link to post
Share on other sites

Jonas, unfortunately this is the problem with DX10 and some textures. there is no fix that i know of at this time and there probably wont be any from MS, nvidia, ati, or anyone else. the only way to fix the problem using dx10 is to get a traffic program that works with dx10. there are a couple out now and one more on the way from flight1. i do agree with you that i like the look and performance of dx10, of course i liked WOAI as well but i have to go with payware for dx10 useage.

Share this post


Link to post
Share on other sites

I've been running Ultimate Traffic for a couple fo years in FS9 and I also bought the "X" version (when I still believed my out-dated box would be able to handle FSX) but it had issues. Also, I've seen more than one "forumist" (here and in other forums) complaining about how the UTrafficX kills the FPS, apparently (if I understood it correctly) because the models weren't properly converted to FSX. When I found WOAI I converted and performance, as well as the "looks", went upwards so I've stuck to it since then.I assume you're referring to "Ultimate Traffic 2" b t w. I'll give that a look and, hopefully, I'll be able to combined the better looks in DX10 with the AI from this product when it comes out.Thanks for the information guys.Cheers/Jonas

Share this post


Link to post
Share on other sites