Archived

This topic is now archived and is closed to further replies.

Guest rdtcmtt

GF-MCP and the Gf_166A

Recommended Posts

hello good folks out there im trying to get these go flight modules up and running , in my level_d 767 and im wondering if anybody in here can tell me how to get this done. i have all of the software loaded and i believe , i have the keys assined but im not for sure.every time i start the sim the led lights go out and i get no response, i have never used these go flight modules with level-d.how do i get this done thanks......Robert

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Did you get the newest software downloaded from GoFlight?Did you set up the GoFlight Configuration manager for Level-D (GF-MCP)?The Configuration Manager defaults to "FS Default", not Level-D!

Share this post


Link to post
Share on other sites

Did you get it to work?Am experiencing a similar issue with Vista. The Goflight modules were working fine with the LVLD in XP!The MCP is working fine with the PMDG however!

Share this post


Link to post
Share on other sites
hello good folks out there im trying to get these go flight modules up and running , in my level_d 767 and im wondering if anybody in here can tell me how to get this done. i have all of the software loaded and i believe , i have the keys assined but im not for sure.every time i start the sim the led lights go out and i get no response, i have never used these go flight modules with level-d.how do i get this done thanks......Robert
Hi I am using the go-mcp pro and the efis with vista 64bits with no problems.The mcp-pro key assignment is automatic.The efis assignment is not automatic,it can be either done through GFconfig or a registered version of fsupci.I intially had problems with the go flight software-after a while I realised the best way to get everything to work was to install the 1.81 driver first and than upgrade to the latest-this combination somehow worked for me.Sal

Share this post


Link to post
Share on other sites

Hi, I guess I am resurrecting an old topic but I recently reinstalled and upgraded my LVLD to FSX and am using the current GoFlight® Module Support Software Version 1.93.20. For the life of me I can not get this to work on Win7/64. I get no LevelD configuration option and the MCP Pro just gives me the dashes and never funtions. I have queired GF (no response) and posted up in the LVLD forum. Nothing working to resolve this. I am a long time MCP Pro user for many AC flawlessly and used to work fine on my old FS9 and XP set up. Just not working on FSX, win7/64 and their newest GF software.Any help greatly appreciated. Not used to fumbling around with a mouse in the cockpit. LOLJoe

Share this post


Link to post
Share on other sites