Archived

This topic is now archived and is closed to further replies.

jbarrydrc

Icing and Airspeed Indicator

Recommended Posts

I have started using ASA (beta installed) and I'm losing my air speed indicator on many flights causing the plane to overstress and crash FSX. I suspect it has to do with the pitot icing up. How can I just disable icing? I have FSUIPC4 installed. Maybe I can just make sure pitot heat is on, but I think I would rather just disable icing altogether. Anyone else having this problem? Thanks.Barry

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have started using ASA (beta installed) and I'm losing my air speed indicator on many flights causing the plane to overstress and crash FSX. I suspect it has to do with the pitot icing up. How can I just disable icing? I have FSUIPC4 installed. Maybe I can just make sure pitot heat is on, but I think I would rather just disable icing altogether. Anyone else having this problem? Thanks.Barry
In FSUIPC you can put off icing. Don't know though if you need the payware version for this.

Share this post


Link to post
Share on other sites

I suspect some aircraft don't model pitot heat correctly or don't handle icing too well. I've had payware aircraft that would zero out until I disabled icing with FSUIPC in FS9. Interestingly enough, flying the MD-11 from PMDG, I haven't had this problem with icing on using ASA. I don't remember what aircraft had this problem or I'd try them again to see. I think the 737NG from PMDG did this a lot. Maybe when I get some time I'll try the 737 again and see.

Share this post


Link to post
Share on other sites