Jump to content

Archived

This topic is now archived and is closed to further replies.

Tallguy

WIN7 RTM, 4GB RAM , FS9 and stil OOM?

Recommended Posts

How can that be? I keep running (on occasions) into an OOM while running WIN7 RTM x64 with 4GB. Everytime this happens taskmanager shows me a RAM usage of 1,96GB.So...it's the 2GB limit again. In XP there was a trick in the boot.ini to up the /userva, but in WIN7?Do I need to add the IncreaseUserVa in the BCD? Or do I need to add the /LargeAddressAware behind the fs9.exe command?

Share this post


Link to post
Share on other sites
Or do I need to add the /LargeAddressAware behind the fs9.exe command?
Absolutely yes you do, you need to edit the fs9.exe and set the largeaddressaware flag with something like mentioned below in the quote , and there is no need to faff about with BCD, that's only needed for 32bit.The below is taken from another thread to get you on the right track
First download the explorer from http://www.ntcore.com/exsuite.phpNext make a copy from fs9.exe. Than start "CFF Explorer" and open the orginal fs9.exe file.Now go to NT Header/File Header and click File Header. There you find a button labeled "click here". Click it. And select the mark at "App can handle> 2gb adressest "Save the modified EXE, overwrite the orginal one (MAKE A BACKUP of the original file before you do the above).

Share this post


Link to post
Share on other sites
Absolutely yes you do, you need to edit the fs9.exe and set the largeaddressaware flag with something like mentioned below in the quote , and there is no need to faff about with BCD, that's only needed for 32bit.The below is taken from another thread to get you on the right track</I>
Thanks Andy! Will give it a try this week.

Share this post


Link to post
Share on other sites

No luck Andy. Changed the flag again, saved the file, deleted the cf9.cfg. Quite soon after starting FS9 (after a couple of seconds) it stops working (and also tells me so :( )And according to taskmgr, my RAM was used up to 2,8GB

Share this post


Link to post
Share on other sites

Interesting...after messing up my FS9, I started to re-install FS9. And you know what Andy? Somewhere along the line the 2gb flag doesn't work anymore.Am trying to figure out when it stops working. Untill know, FS (with the flag set) the FS 9.1 update nor PMDG MD-11 interferes...so...I'll have to continue installing my AI and mesh.

Share this post


Link to post
Share on other sites

So far I've found out that the bglman.* files, installed when installing Cloud9 EHAM, will result in a crashing FS. Will try with a new Cloud9 toolkit to get the latest bglman files.

Share this post


Link to post
Share on other sites

Woohoo :( The >2gb fix in fs9.exe did work Andy!2cgldv6.jpg3.17Gb RAM in use, both CPU's working for FS9 (had to turn off 1 CPU in taskmgr and then turn it on again to get both CPU's working).Running FS9, FSGlobal2008, UT Europe, MD-11, ASA, RealEnvironment Pro, RC4, VRinsight MCP combo, GF-TQ6 & GF-T8 ... all on 1920x1200 @32bit with almost everything at 100% and NO OOM! :( And the CTD was due to some bglman files from Cloud9. After fixing those with their new tool and copying them right over the originel ones, no more CTD.

Share this post


Link to post
Share on other sites

Now I'm only trying to figure out if it's 'needed' to increase my RAM to 6GB or 8GB.Anyone any thoughts about that?

Share this post


Link to post
Share on other sites

You wont see FS9 use any more memory that you mentioned previously so it would be a waste of time, the same is true of FSX because both apps are still 32bit programs at the end of the day.

Share this post


Link to post
Share on other sites

Hey Andy,Just got FSX up and running with Acceleration, REX (installed, not active) en FEX (installed, not active) and had it running with TrackIR. My system was then using a whopping 3.98GB RAM :( True I run at 1920x1200 with DX10 activated (since I was planning on getting the PMDG JS41), but still...quite a lot.I'm gonna figure out why there's so much RAM used.

Share this post


Link to post
Share on other sites

How much memory does your graphics card have, I would bet that it is one of the Nvidia cards with more than 1Gb of VRAM, Vista shadows (I think that is the correct term) the VRAM contents in system RAM so this is probably why you are seeing more used in FSX as FSX can use a lot more VRAM than FS9 add-ons tended to do.

Share this post


Link to post
Share on other sites

I had the same problem after I installed some heavy scenery until I fixed it today. I am on WinXP SP3FS9.12.99Gb RAM I downloaded and run the "4GB Patch" by Daniel Pistelli which does exactly what is explained above but with a single click. http://www.ntcore.com/4gb_patch.php(Altn.location http://www.softpedia...4GB-Patch.shtml ) Now instead of crushing at 1.95~2.0 Gb I crashed FS9 at 2.4 Gb memory usage. I won't go that high unless I open many browser pages etc. (which I did intentionally on last trial to see how far it can go). Regards

Share this post


Link to post
Share on other sites
no, it's a 8800GT 512MB card. Which reminds me...I need to put it in my signature.
Also something to look at:Verify that there is no Landclass listing in your Scenery.cfg with a TEXTURE folder. Landclass should have only SCENERY folder, otherwise FS9 will try to read that "blank" texture folder and will use all of your RAM.Pierre

Share this post


Link to post
Share on other sites

×
×
  • Create New...