Jump to content

Archived

This topic is now archived and is closed to further replies.

jelvers

Windows7 Out of Memory (OOM) Error

Recommended Posts

Just installed FSX SP2 under W7 32 bit. Computer equipment: see below. FSX runs very smoothly, however get Out of Memory (OOM) error, when RAM intensive scenery applied (such as Aerosoft's Hamburg airport scenery). Refer to Nick's article concerning OOM error with Vista 32 bit (http://www.simforums.com/forums/forum_posts.asp?TID=29041), where he recommends to free up more memory by applying the command:BCDEDIT /set increaseuserva 2560This worked great with Vista 32 bit. Can I apply the same command with Windows 7 to get rid of the error.Advice highly appreciated.Rgds, JuergenDell XPS 420Intel Quad Core CPU Q6600 2.40 Ghz4 GB RAMNvidia GF 8800 GTX 768 MB

Share this post


Link to post
Share on other sites

Hi JuergenNo sure about the edit under Windows7 - I am sure someone will confirm either way shortly.What I am curious about is why on earth did you install the 32bit version of Windows7?


Konrad

Share this post


Link to post
Share on other sites
Hi JuergenNo sure about the edit under Windows7 - I am sure someone will confirm either way shortly.What I am curious about is why on earth did you install the 32bit version of Windows7?
And I also had the same thought when I read the post.....I switched over to 64b from 32b and will never go back..FSX runs much better...Lou

C172P N97674
PPL SEL
Complex
High Performance

Share this post


Link to post
Share on other sites
And I also had the same thought when I read the post.....I switched over to 64b from 32b and will never go back..FSX runs much better...Lou
Thanks Lou. Yes, have the 32 bit version of W7. Am considering to switch, but need W7 32 bit for other reasons stiil. Therefore unfortunately need to solve the problem under the 32 bit version.Regards, Juergen

Share this post


Link to post
Share on other sites

Win7 32bit will still utilize only 2GB of memory... I'm not sure the 3GB switch parameters from Vista woks on Win7. There might be a different approach to activate the 3GB switch on Win7.In this case, I recommend you to upgrade to 64 bit Win7BR.

Share this post


Link to post
Share on other sites
Win7 32bit will still utilize only 2GB of memory... I'm not sure the 3GB switch parameters from Vista woks on Win7. There might be a different approach to activate the 3GB switch on Win7.In this case, I recommend you to upgrade to 64 bit Win7BR.
Many thanks. Yes, I will also build up a 64 bit system. But I have to stick on my current system to 32 bit and am looking for a solution there. I tried the bcdedit /set IncreaseUserVA 2560 but without real success. Sometimes it works ok and then I get the OOM error again (probably dependent on open programs and scenery?).Does anybody know whether I should lower or increase the 2560. Have read elsewhere that going up may lead to difficulties to start up Windows (at least Vista)?Regards, juergen

Share this post


Link to post
Share on other sites
Guest firehawk44
Just installed FSX SP2 under W7 32 bit. Computer equipment: see below. FSX runs very smoothly, however get Out of Memory (OOM) error, when RAM intensive scenery applied (such as Aerosoft's Hamburg airport scenery). Refer to Nick's article concerning OOM error with Vista 32 bit (http://www.simforums.com/forums/forum_posts.asp?TID=29041), where he recommends to free up more memory by applying the command:BCDEDIT /set increaseuserva 2560This worked great with Vista 32 bit. Can I apply the same command with Windows 7 to get rid of the error.Advice highly appreciated.Rgds, JuergenDell XPS 420Intel Quad Core CPU Q6600 2.40 Ghz4 GB RAMNvidia GF 8800 GTX 768 MB
It works in Windows 7 32 bit: http://msdn.microsoft.com/en-us/library/aa906211.aspx. Actually I would set the memory to 2048 (2GB) vs 2560. That's what I had mine set to when I had a 32 bit system but then I had TWO 8800GTX w/768MB memory. I was getting OOM's too at 2560 and 3072. If that doesn't work, you are going to have to reduce your FSX sliders until the OOM's stop (while still setting memory allocation at 2049). Also make sure you have defragged the hard drive after installing FSX and after any scenery addons. Windows does a lousy job installing files and files are usually scattered all over your hard drive making it difficult for FSX to seek a file, read it, then execute. I'm curious to know whether Windows 7 is "seeing" all your memory (right click the desktop Computer icon and select Properties or click on Start then right click the Computer and select Properties if you have no Computer icon on your desktop). You should do this to make sure your memory is functioning properly (they do go bad occasionally!). One last thing, make sure your page file (virtual memory) is being properly managed and is set at "System Managed". Hope this helps.Best regards, Jim

Share this post


Link to post
Share on other sites
It works in Windows 7 32 bit: http://msdn.microsoft.com/en-us/library/aa906211.aspx. Actually I would set the memory to 2048 (2GB) vs 2560. That's what I had mine set to when I had a 32 bit system but then I had TWO 8800GTX w/768MB memory. I was getting OOM's too at 2560 and 3072. If that doesn't work, you are going to have to reduce your FSX sliders until the OOM's stop (while still setting memory allocation at 2049). Also make sure you have defragged the hard drive after installing FSX and after any scenery addons. Windows does a lousy job installing files and files are usually scattered all over your hard drive making it difficult for FSX to seek a file, read it, then execute. I'm curious to know whether Windows 7 is "seeing" all your memory (right click the desktop Computer icon and select Properties or click on Start then right click the Computer and select Properties if you have no Computer icon on your desktop). You should do this to make sure your memory is functioning properly (they do go bad occasionally!). One last thing, make sure your page file (virtual memory) is being properly managed and is set at "System Managed". Hope this helps.Best regards, Jim
Jim, many thanks. Yes, the installed memory is shown correctly and virtual memory is indeed set at "system managed". I'll try further with your other recommendations. But just one question: isn't the "2048 set" the standard one in W7 32 bit?Best regards, Juergen

Share this post


Link to post
Share on other sites

×
×
  • Create New...