Jump to content

Archived

This topic is now archived and is closed to further replies.

jfri

Problem using ASA with FSX in network

Recommended Posts

I got ASA on client computer with Win XP. I used Win 7 RC on the server running FSX (and FS9). Then both FS9 and FSX worked with ASA.Now I have installed my Win 7 Home Premium 64 bit on the sever computer. Fs9 works fine with WideFS. But I can't get FSX to work through simconnect.I have copied simconnect.xml to its proper location and edited it according to instructions. I suppose I should use the global server configuration entry.I have enabled port=500 in both firewalls and ASA gives no errormessage. Running AItraffic utility gives no messages at all.

Share this post


Link to post
Share on other sites

Hi,Make sure both computers belong to the same network. Win 7 is a bit different in this regard. Keep using the AI Traffic utility as that is a better test to the network.Thanks,

Share this post


Link to post
Share on other sites
Hi,Make sure both computers belong to the same network. Win 7 is a bit different in this regard. Keep using the AI Traffic utility as that is a better test to the network.Thanks,
What do you mean by 'both computers belonging to the same network'? I'm not aware of having more than one network. When using the IP address I do see different information given. There are under Win 7 entries for a IPv4 address and Ipv4 default gateway and Ipv4 DHCP server and IPv4 DNS servers (two IP addresses given). In the WinXP system there are info about a IP-address and also a Standard-Gateway address. Which should be used?I got MS Acceleration SDK installed on the server and simconnect.xml and Simconnect DLL EXE XML files where fsx.cfg is. Was there more needed on the server computer?

Share this post


Link to post
Share on other sites

Hi,The Names of the networks on the 2 computers must be the same. It is my understanding from reading other posts that Win 7 does not do a good job in this area.What is the name of the Network that the server machine belongs to?What is the name of the Network that the client machine belongs to?You need to use the local IP address: Control Panel---Network Connections---Right Mouse Click---Status---Support Tab---IP AddressMost of the time it starts with 192SDKs get installed on the client computer in order to get SimConnect installed on the client computer. They do not get installed on the server computer. We do not ask for SimConnect DLL.exe to get installed anywhere.2 files go on the server: SimConnect.xml and SimConnect.ini1 file goes on the client: SimConnect.cfgThanks,

Share this post


Link to post
Share on other sites
Hi,The Names of the networks on the 2 computers must be the same. It is my understanding from reading other posts that Win 7 does not do a good job in this area.What is the name of the Network that the server machine belongs to?What is the name of the Network that the client machine belongs to?You need to use the local IP address: Control Panel---Network Connections---Right Mouse Click---Status---Support Tab---IP AddressMost of the time it starts with 192SDKs get installed on the client computer in order to get SimConnect installed on the client computer. They do not get installed on the server computer. We do not ask for SimConnect DLL.exe to get installed anywhere.2 files go on the server: SimConnect.xml and SimConnect.ini1 file goes on the client: SimConnect.cfgThanks,
Where do I see these names? In Win 7 I see names like Homegroup Workgroup. In Win XP (client) Anslutning till lokalt n

Share this post


Link to post
Share on other sites

Hi,Right mouse click on My Computer and go to the Computer Name Tab. Look at "Workgroup". Both computers should belong to the same Workgoup. It doesn't matter what the client IP address is, only the Server IP address.Thanks,

Share this post


Link to post
Share on other sites
Hi,Right mouse click on My Computer and go to the Computer Name Tab. Look at "Workgroup". Both computers should belong to the same Workgoup. It doesn't matter what the client IP address is, only the Server IP address.Thanks,
Now I have come so far that the AItraffic utility displays a FSX connected message. Also when starting ASA the log displays messages about SimConnectfound and initialized and Simconnect SP2 instantiated. Still ASA does not update any weather inside FSX. I have selected custom weather in FSX

Share this post


Link to post
Share on other sites

Hi,No, if ASA and FSX are connected weather should automatically be set to User Defined. You don't chose anything in FSX.Is Lock to Closest On in ASA?On the Map Screen can you click on the Lock to FS position box?Let ASA and FSX run for a bit and then post your ASA_Log.txt file.Thanks,

Share this post


Link to post
Share on other sites
Hi,No, if ASA and FSX are connected weather should automatically be set to User Defined. You don't chose anything in FSX.Is Lock to Closest On in ASA?On the Map Screen can you click on the Lock to FS position box?Let ASA and FSX run for a bit and then post your ASA_Log.txt file.Thanks,
Yes lock to closest on and KSEA displayed as closest in spite of being at KEWRNo when I click on lock to FS position box it won't display as checkmarked and position remains KSEA.The ASA_Log.txt only contain this ,16:03:30:0578 - Flight Plan Retrieved - Dataset data about to be processed21:36:28:0546 - Flight Plan Retrieved - Dataset data about to be processed

Share this post


Link to post
Share on other sites

Hi,Is that the whole ASA_Log.txt file? There should be lines in there while ASA is starting. And those times are like 5.5 hours apart.All the other things point to SimConnect not connecting to FSX still.I am not sure to suggest a clean reinstall of ASA or the SimConnect version clients.Right now try and get another ASA_log.txt file: Run ASA, run FSX, close both down and post the file.Thanks,

Share this post


Link to post
Share on other sites
Hi,Is that the whole ASA_Log.txt file? There should be lines in there while ASA is starting. And those times are like 5.5 hours apart.All the other things point to SimConnect not connecting to FSX still.I am not sure to suggest a clean reinstall of ASA or the SimConnect version clients.Right now try and get another ASA_log.txt file: Run ASA, run FSX, close both down and post the file.Thanks,
Yes that was the whole file and it is exactly the same after trying your suggestion. Also I see it si marked as changed last time 2009-09-09. My current ASA and SimcConnect version has been working before when I run FSX under Win 7 RC. The problem has arised after installing the coomercial Win 7.

Share this post


Link to post
Share on other sites

Hi,So the new ASA_Log.txt file is exactly the same, and is dated 9-9?Somehow the new install of Win 7 has changed something on your network. Did you do a fresh install of Win 7 after using the RC?Thanks,

Share this post


Link to post
Share on other sites
Hi,So the new ASA_Log.txt file is exactly the same, and is dated 9-9?Somehow the new install of Win 7 has changed something on your network. Did you do a fresh install of Win 7 after using the RC?Thanks,
Yes exactly the same and dated 9-9 Yes fresh install

Share this post


Link to post
Share on other sites

Hi,And you went through the Networking Chapter and set everything back up again on the server and the client?Thanks,

Share this post


Link to post
Share on other sites

×
×
  • Create New...