Archived

This topic is now archived and is closed to further replies.

Capt. Windh

V-synch question (tearing)

Recommended Posts

Hi.I am on the verge of ordering a copy of X-plane 9.I have one question though: Is there a fix for the vertical tearing that I get? (V-synch problems)I can

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi.I am on the verge of ordering a copy of X-plane 9.I have one question though: Is there a fix for the vertical tearing that I get? (V-synch problems)I can

Share this post


Link to post
Share on other sites

In the rendering screen there should be an option called "lock framerate to monitor refresh rate", be sure it's selected.Marco

Share this post


Link to post
Share on other sites

I had the same problems, if you use an nvidia card, you can enable V-sync from nhancer and voila' it's fixedalso nhancer has better AA options, ex. 4XS mode works the best for me.

Share this post


Link to post
Share on other sites

Hmm.. I cannot seem to find those AF-settings... The AA works splendid.. But the vertical tearing remains... Any ideas?//Johan

Share this post


Link to post
Share on other sites
Hmm.. I cannot seem to find those AF-settings... The AA works splendid.. But the vertical tearing remains... Any ideas?//Johan
The AF (Anisotropic Filtering) is on the rendering options screen below where the shaders settings are.As to the tearing - AFAIK if your frame rate is below the rate you set under 'lock frame rate' then you will still get tearing i.e. if your monitor refreshes at 60Hz and it's locked to half that you need to be getting at least 30fps for it to be effective - Off the top of my head I can't see any way around that at present.As to triple buffering in X-Plane it's a new one on me.Setanta

Share this post


Link to post
Share on other sites
As to the tearing - AFAIK if your frame rate is below the rate you set under 'lock frame rate' then you will still get tearing i.e. if your monitor refreshes at 60Hz and it's locked to half that you need to be getting at least 30fps for it to be effective - Off the top of my head I can't see any way around that at present.As to triple buffering in X-Plane it's a new one on me.Setanta
Both Nvidia and ATI have a v-sync option in their control panels. They also have an option to enable triple buffering with OpenGL applications.

Share this post


Link to post
Share on other sites
Both Nvidia and ATI have a v-sync option in their control panels. They also have an option to enable triple buffering with OpenGL applications.
Ahhh, so it's external to X-Plane itself - explains why I hadn't seen it :) Neither vendor supplies a control panel for OS X, I don't know about Un*x based systems but I doubt it. Think I'll have a look and see if there's a hack somewhere. Thanks for the info :)SetantaA quick check later and my best guess is that triple buffering is enabled by default under OS X on machines that support Quartz Extreme - Assuming that X-Plane does its own double buffering (it would need to) and runs in a window (it does, even in full screen mode) - Probably why I never see any tearing these days :)Setanta

Share this post


Link to post
Share on other sites