Archived

This topic is now archived and is closed to further replies.

Virgin_A340

Keyboard Not Responding

Recommended Posts

I have had the 737 working fine and it had no problems on my last flight. I have not changed the installation at all since then but now the keyboard commands don't work. I mean things like pressing S to chance the view or alt to display the menu bar. No of them do anything. All the joystick and panel mouse clickspots/switches work fine. The keyboard commands work fine in my other add-ons, it's just the 737 that isn't working.Any idea what could be causing this?Andy S

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have had the 737 working fine and it had no problems on my last flight. I have not changed the installation at all since then but now the keyboard commands don't work. I mean things like pressing S to chance the view or alt to display the menu bar. No of them do anything. All the joystick and panel mouse clickspots/switches work fine. The keyboard commands work fine in my other add-ons, it's just the 737 that isn't working.Any idea what could be causing this?Andy S
Did you turn on the keyboard function in the FMS?

Share this post


Link to post
Share on other sites
Did you turn on the keyboard function in the FMS?
No. I have never used this feature.When I just checked again now I start FS9 and load the default Cessna. The keyboard works fine. I then pressed alt to get the menu and switched straight to the PMDG 737 and the keyboard wasn't working again. So it's not a case of it not loading or something as it works fine in the same session before switching to the 737. Andy S

Share this post


Link to post
Share on other sites

Im having a problem with this too, when i use Shift+p to pushback, its not doing anything, it might be the FMC thing you mentioned George, ill give that a try.Greg Patrick

Share this post


Link to post
Share on other sites
Im having a problem with this too, when i use Shift+p to pushback, its not doing anything, it might be the FMC thing you mentioned George, ill give that a try.Greg Patrick
Greg can you use any of the other keys or is it just the Shift+P that's not working for you?If you try the FMC thing can you report back.

Share this post


Link to post
Share on other sites
Greg can you use any of the other keys or is it just the Shift+P that's not working for you?If you try the FMC thing can you report back.
Andy it is important that you sign your posts with your full name. If you don't follow the forum rules then the post could get locked or deleted. Have you tried to turn on and off the FMS keyboard function? Are you doing anything special with FSUIPC? Have you done any keyboard mapping? Do you have any other hardware and add-ons?

Share this post


Link to post
Share on other sites

I tried turning on and off the FMC keyboard function and still it doesn't work. If I reinstall the 737 will I have to reinstall the 747 as well?Andy S

Share this post


Link to post
Share on other sites

I've tracked down and sorted it. FSUIPC was somehow changed to an older version without me knowing.Is there a way of setting FSUIPC to never be changed?Andy S

Share this post


Link to post
Share on other sites

First, install the latest version form here:http://www.schiratti.com/dowson.htmlor the latest beta from here:http://forums.simflight.com/viewtopic.php?...b7036ef224def92If you are running VISTA or Win 7 run the install as an administrator.Find your way (as an admin) to your FS modules folder. Right click on FSUIPC.dll and select properties. I use XP. Set the Attribute to Read Only. There may be a better way in VISTA or Win 7 especially if you run in admin mode but I think you'll get a warning anyway. Do not set Read Only for FSUIPC.ini as that gets updated frequently. If updating FSUIPC be sure to unset Read Only first so it can be overwritten.What happened I suspect you loaded something that required FSUIPC and did not check your loaded version and just overwrote it with its own older version.

I've tracked down and sorted it. FSUIPC was somehow changed to an older version without me knowing.Is there a way of setting FSUIPC to never be changed?Andy S

Share this post


Link to post
Share on other sites