Sign in to follow this  
Bert Pieke

Nvidia Driver and FS2004

Recommended Posts

All,I have to conclude that all of the Nvidia drivers that support FX cards have problems in FS2004. This problem appears only when you use full-screen and have AA turned on in the driver setting. AF does not create the problem.Create a Flight menu is blank, except the 3-D model of your aircraft. Also, try going to your View Option menu - I bet that is blank too. These issues do not occur in Window view within FS9.To fly with full-screen and have AA, use the AA enabled within the game, and in the NVidia driver software, set AA = application, and set AF = x2,x4, etc.Or,You can use AA from the driver (disable AA from FS9) but will have to change from full-screen to window mode (ALT-Enter in FS9) each time you want to view the Create a Flight menu - not the best way to fly IMHO. I have personnally used drivers 44.03 WHQL, 44.67, 44.71 WHQL, and now 45.20. :-(Please send e-mail to NVidia and let your voice be heard!Send to info@nvidia.comCloud9

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm using almost the same system but with a lesser speed chip. Try the 45.20 with directx 9b. There was a definite difference between the 9a and 9b in terms of performance. I have an ASUS P4C800 Deluxe with an INtel 2.4Ghz with 800 Mhz FSB 2x512DDR, MSI Fx5600 with 256MB and the only problem I have is with an constant popping sound when using the Lear and flying through multiple complex 3D cloud layers. Im using the quality settings with 4xAA, 2xAF @1024x768 wiht 32bit colors. I have none of the problems others have had with nvidia cards with the GPS window nor with any of the menus. I'm only using full-screen mode in the sim.

Share this post


Link to post
Share on other sites

PHL, I think you are the only one that is not having problems with FS2004 in full-screen mode. Go to your Create A Flight menu in full-screen (non-window mode). Do you get a black screen? I have used the most current drivers, including the beta 44.20. And I use DX9b. It is a driver issue of some sort. I'm not sure why you are not experiencing the display issue in full-screen.Interesting,Cloud9

Share this post


Link to post
Share on other sites

I have the identical behavior.. Ti4200, 44.03 drivers.The workaround is to start the sim and close down the sim in windowed mode. Use full screen only for actually flying.I've tried a handful of other drivers.. none of them fix this problem on my machine.Best overall visuals with 2xAA and 4xAF enabled from outside FS2004. Enabling AA from within FS seems to give you 4xAA which impacts framerates on my machine and does not look any better..

Share this post


Link to post
Share on other sites

I'm using 44.03 on a Ti4600 with AA turned ON in the sim and OFF in the card (read somewhere about doing that) and it is working a treat.Bill

Share this post


Link to post
Share on other sites

Well im using the 45.20 on a geforce fx 5200 with absolutley no problems either. Also using directx 9b btw.

Share this post


Link to post
Share on other sites

>To fly with full-screen and have AA, use the AA enabled within>the game, and in the Nvidia driver software, set AA =>application, Have you tried disabling AA in FS and then selecting AA=4x in the driver menu?Just to clarify for some:Setting AA=application means just that, the app will now control AA. So if you don

Share this post


Link to post
Share on other sites

If you have AA ON in FS, and OFF in the card.. you have no AA enabled and you will not have any of the full screen problems, but no AA either..

Share this post


Link to post
Share on other sites

>If you have AA ON in FS, and OFF in the card.. you have no AA>enabled and you will not have any of the full screen>problems, but no AA either..Should have worded it a bit better - sorry.The card is set in the configuration to Application - i.e. FS9 sorts out what it wants and FS9 is set to 4xRead in one of the forums somewhere this was the way to go about it and it worksBill

Share this post


Link to post
Share on other sites

Don't know if you tried this yet or not. I am running with an FX5900 with no problems except a little shimmer. If I set the AA at 2X I get your problem. If I set it at 4X or higher it works fine.I disable AA in the sim and run it from the card. I am using the 44.67 drivers.Hope you get the issue solved.Dave Spurlock

Share this post


Link to post
Share on other sites

OK.. understand.. we all have the same issue:FS9 2xAA in full screen has problems with 4x.xx series drivers.The 30.82 drivers do work, but do not have all the latest features..4xAA is OK.. No driver released by Nvidia fixes this.Workaround is to go to Windowed mode to access menus, kneeboard, etcor.. turn off AA, or go to 4xAA and accept the fps penalty..

Share this post


Link to post
Share on other sites

>OK.. understand.. we all have the same issue:>>FS9 2xAA in full screen has problems with 4x.xx series>drivers.>The 30.82 drivers do work, but do not have all the latest>features..>>4xAA is OK.. >>No driver released by Nvidia fixes this.>>Workaround is to go to Windowed mode to access menus,>kneeboard, etc>or.. turn off AA, or go to 4xAA and accept the fps penalty..Hi Bert,You seem to have dilgently pursued and documented this issue :) I am just wondering if you or any others with the problem have tried the stock Nvidia 42.30 driver? I don't seem to have seen this driver version mentioned anywhere yet in relation to this issue. This is actually an Nvidia WHQL certified driver, but it was never available for download from Nvidia's site. I have been using the driver with excellent results in all D3D based applications (including FS2002 but not yet FS2004) for quite a while now.The problem is that FS2004 isn't available in my country yet, so I don't know if this driver helps at all with the problem or not. I suspect this 42.30 driver might have been one of the last "pre FX" drivers, so it might be worth a go. I got it at guru3d. This issue is certainly of concern to me, as I have always felt that the very best compromise between IQ and performance was 2 x AA. I wouldn't mind going back to the 30 series drivers, except that they had an ATC / red overlay text corruption issue in FS2002 whenever anisotropic filtering was enabled.

Share this post


Link to post
Share on other sites

I've actually stopped experimenting, but instead am enjoying exploring the sim! The reason I've stayed with the 44.03 drivers is that they are nvidia's latest official drivers (according to the nvidia.com site..) and they have the AA and AF settings easily accessible. The 30.82 drivers are a different way around the problem, but you need Rivatuner or such to enable AF settings.Do not be too concerned! The 44.03 drivers produce really good looking visuals and good framerates.. and the full screen / window issue can be circumvented by pushing a couple of keys from time to time..At first I just wanted to know if only I had this issue, but it seems to be widely reported now.. I'm still surprised that this was not caught, or at least documented in the MS knowledgebase acticle that lists countless other video card dependencies for FS9..

Share this post


Link to post
Share on other sites

Thanks for the links to those posts.Two comments:1) The problems are linked to BOTH card and drivers. I found that using 44.03 with an FX leads to 2D panel problems, while 44.03 with a GEForce 4 series card does not.2) Its nice to know that 44.67 drivers are needed with an FX card - too bad they aren't available for Win9x users.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this