Sign in to follow this  
Guest k2kwr

Something A Bit Interesting Regarding FS2004

Recommended Posts

Well, FS9 is one heck of a sim. It's beautiful, graphics are just 100% realistic, and so is the fly experience. But, it runs really crappy on my system. Yes, I looked at all the FAQs, yes I updated my drivers, and I even tweaked my system by making sure programs that I do not need are not running in the background. But, no avail. It's just hideous FPS for me. My system is a laptop with the following specs:2.66MHz Pentium 4 processor; 69GB Hard Drive, 1GB of RAM, and a 64MB Radeon IGP 345M.My frame rates are between 3-5 in major cities, and about 11-15 during cruise, in the 3D clouds it goes down to about 2.5 - 3 FPS. My settings are rather low, especially for the clouds.So, what's making the sim run like that? Does the fact that my system is a lapatop have anything to do with this? Or is there something else I could do?Any advice or suggestions would be greatly appriciated. It gets really frustrating when you're on final approah and your FPS drop to 2.5-3.Thanks in advance,

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Well, it's not your processor or ram. The video card is weak for sure. What are you running the various sliders on? We have the same processor and ram, and my sys is running the sim beautifully, except in the worst of multilayered clouds. I am able to land at major terminals and maintain a frame lock around 22-25 with most sliders maxed, and 38 or better meter mesh. Why don't you post a screen shot of your various display settings in FS9 for starters. Mine are posted below . . .Noel

Share this post


Link to post
Share on other sites

The first changes you should make are to uncheck the Anti-aliasing and the Aircraft Shadows. Those two items are definitely eating up your frame rates.If you don't see much improvement (and you should), then move the detail sliders down one setting for Scenery Complexity and AutoGen Complexity. I would also check the box for Transform & Lighting to improve your scenery out the window and get a slight boost on the graphics.The less significant tweaks, if you still are not happy with frame rates is to move the Terrain Mesh Complexity down to 70 or so and you will not see much difference in the terrain, but it will help the frame rates.If you are getting decent frame rates, then try setting Terrain Texture size to High and you will see more defined ground textures.There are more tweaks, but try these first and see if your sim improves.Bruce

Share this post


Link to post
Share on other sites

Also turn your transform and lighting on-that seems to add to performance quite a bit. Ditto on the aa-turn it off!One of the biggest ones that seems to get missed are your visiblity settings. fs will often select "unlimited" with real weather downloads etc. Limit your visibility to a max of 30-40-turn it down further to see an even better increase.I was up flying yesterday on a rare unbelievable day where I live-40 miles visibility-but most of the time 10-20 is exceptional-and often much lower.http://mywebpages.comcast.net/geofa/pages/Geofdog2.jpg

Share this post


Link to post
Share on other sites

Tried, not that much of a difference. Updated windows and everything and still choppy rates. Any other tips?

Share this post


Link to post
Share on other sites

I've been led to believe that it is the "ground scenery casts shadows" that affects frame rate more than "aircraft shadows," so I would definitely uncheck that one. Also, I would experiment with lowering the display resolution (I would try the 1024x768 first -- if it helps, then you can decide which you prefer - the higher frame rates or the higher resolution). Finally, I would set a target frame rate of 20-25.Don S.

Share this post


Link to post
Share on other sites

Since you don't have a powerful graphics card in your laptop, another change to make is to lower your display resolution to 1024x768x32. That will free up your processor a little.

Share this post


Link to post
Share on other sites

Set mesh complexity to 0. All it will do is smoothen the horizon a bit, hardly noticeable.Turn off lensflare. It's highly unrealistic and takes processor power to calculate so you don't want it for 2 reasons.Turn off scenery shadows.Turn off aircraft shadows.Set 3D cloud percentage lower, 50% or so.Lock framerates to 20.Turn off anti-aliassing (you can try if hardware AA gives a bad hit later in the videocard properties in Windows).Change display resolution if your laptop screen can display more than one.1024x768 or 1280x1024, even 1600x1200 are easier on the CPU and videocard than 1400xwhatever due to the way DirectX and videocards work.

Share this post


Link to post
Share on other sites

Also reduce Autogen. At your setting it will have a substantial effect on FPS.Happy Flyin' - Ken

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this