Archived

This topic is now archived and is closed to further replies.

jabjoker

VC View Problems with SAITEK Yoke System

Recommended Posts

I recently replaced my CH Yoke (it was well used) & throttle quadrant with Saitek Pro Flight Yoke two throttle quadrants as well as a Multi Panel & Radio PanelI have not been able to use the system.When I load FSX in virtual cockpit the view goes to the top, after panning down it goes backward again.I have searched various forums to no avail.Also when booting up FSX I get a green screen which dissapears once I have pressed Alt-TabShould I re-install FSX? (Something I am very reluctant to do because of all the third pary add-ons I have)Any guidance would be highly appreciatedHans Brokke

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you calibrated all the hardware?It appears that something is sticking - is there a POV (hat switch) on any of your devices?Can you just plug each device in separately?

Share this post


Link to post
Share on other sites

HansYou may have a duplicate assignment for panning. FSX will do this without you knowing I've even see the pan switch assigned to the rudder pedals! Cheack all of your gaimng controller axes including the mouse! If yopu are running the SST software (not drivers) that's another area to make sure that you have no duplicate assignments. Likewise if you are running FSUIPC4!RegardsPeterH :rolleyes:

Share this post


Link to post
Share on other sites
Have you calibrated all the hardware?It appears that something is sticking - is there a POV (hat switch) on any of your devices?Can you just plug each device in separately?
Hi ThereThanks for your prompt reply.I use FSUIPC for all my settings, I have deleted all duplicates for example only the POV on the SAITEK yoke has been set in (the Logitech Extreme 3D has been cleared), the Calibration page of the FSX Settings-Control Menu has been disabled on the "Enable Controller's" section. All Joystick commands on the "Buttons/Keys" page for the Mouse Yoke & Mouse Look have been removed. All without avail.
HansYou may have a duplicate assignment for panning. FSX will do this without you knowing I've even see the pan switch assigned to the rudder pedals! Cheack all of your gaimng controller axes including the mouse! If yopu are running the SST software (not drivers) that's another area to make sure that you have no duplicate assignments. Likewise if you are running FSUIPC4!RegardsPeterH :rolleyes:
Hi Peter,Thanks for your prompt reply.I use FSUIPC for all my settings, I have deleted all duplicates for example only the POV on the SAITEK yoke has been set in (the Logitech Extreme 3D has been cleared), the Calibration page of the FSX Settings-Control Menu has been disabled on the "Enable Controller's" section. All Joystick commands on the "Buttons/Keys" page for the Mouse Yoke & Mouse Look have been removed. All without avail.RegardsHans

Share this post


Link to post
Share on other sites
Have you calibrated all the hardware?It appears that something is sticking - is there a POV (hat switch) on any of your devices?Can you just plug each device in separately?
Hi ThereYes my Yoke & Logitech have POV I disabled the one on the Logitech Yes I can unplug each of the devices, the problem disapears the minute I unplug the Saitek Flight Yoke

Share this post


Link to post
Share on other sites
Have you calibrated all the hardware?It appears that something is sticking - is there a POV (hat switch) on any of your devices?Can you just plug each device in separately?
Please note after 10 days of frustration I have decided to un-install FSX & re-install FSXHave done the basics & added one of my third party aircraft & so far so good.Hopefully this wiil remain so once I have re-installed all my other 3RD Party Software.Thanking you all

Share this post


Link to post
Share on other sites