Jump to content

Archived

This topic is now archived and is closed to further replies.

BadKarmaPT

Anyone else has this problem?

Recommended Posts

Hello,I'm running FS9 on Windows 7 x64 and a GTX470 and I have this issue that is driving me crazy. I've spent more time trying to solve this issue than I've spent flying! :( When I press ALT to access the menu the screen goes black for a second or two and then I'm able to see windows that I had opened and closed before.The menu bar stays on top of a black screen with "ghostwindows" and the FS9 view only returs after closing the menu bar either by choosing something from the menu or pressing ALT again.This is a bit tricky to explain so I'll post a screenshot.When I press "Fly Now" the screen also flickers a couple of times but I can live with this.I also had an issue with the mouse pointer turning black when I pressed ALT to access the menu but I was able to solve this issue by changing the mouse pointer profile to "None".I changed the properties of my FS9 shortcut to "disable desktop composition" but that didn't help.I have also tried different driver versions without success.Any tips? Thanks in advance.

Share this post


Link to post
Share on other sites

I assume you are running in full screen mode? If so, there are known issues with FS (and FSX) with the nVidia cards and drivers under Win7 x64. Some folks say they have no problems or have solved the problem - many haven't and I'm one of them. I got tired of messing about with it and now running happily with a full screen window. So far as I'm aware there is no known universal fix for this.DJ

Share this post


Link to post
Share on other sites

Hi DJ,Thank you for your input.Yes, forgot to mention I'm running fullscreen at 1920x1200 (my monitor's native resolution).Strangely enough I don't have any of these issues with FSX and I'm almost sure I didn't have any with FS9 either the first few times I ran it right after installing Win 7 x64.Seems as if something changed but what? :(

Share this post


Link to post
Share on other sites
Hi DJ,Thank you for your input.Yes, forgot to mention I'm running fullscreen at 1920x1200 (my monitor's native resolution).Strangely enough I don't have any of these issues with FSX and I'm almost sure I didn't have any with FS9 either the first few times I ran it right after installing Win 7 x64.Seems as if something changed but what? :(
No telling... I had the issue on two separate computers running both FS9 and FSX the first time I tried them; the only common denominator was they both used nVidia cards and the same driver version. Subsequently, I've changed drivers several times but the issue remains. Fortunately, on powerful machines, the windowed mode is just as fast as full sceen and I have gotten to appreciate being able to get to the desktop.DJ

Share this post


Link to post
Share on other sites

Thank you for your help Tom but I wish it was that easy.I'm running the Classic Theme with every effect off and as I mentioned in my first post I'm running FS9 with the "Disable Desktop Composition" option checked since I noticed this problem.Thanks anyway.

Share this post


Link to post
Share on other sites

Hello again,Just a quick update.I went into "Advanced System Settings"/ "Performance Settings"/ "Visual Effects" and chose "adjust for best performance" (every option unchecked) besides making Windows 7 look like Windows 98 it didn't help.I had faith one of these options was causing the issue but I guess I was wrong.Back to the drawing bord. :( Just to let you know...

Share this post


Link to post
Share on other sites

Hello,Yet another update!I was able to minimize this problem by right-clicking the FS9 icon and selecting under options>shortcut "run maximized" instead of "run normal window".This does not solve the issue completely but helps by reducing the time the screen stays black when you press the ALT key.Hope you'll find this helpful. :(

Share this post


Link to post
Share on other sites

×
×
  • Create New...