Archived

This topic is now archived and is closed to further replies.

majapahit

LINDA Mode toggles only when LINDA started?

Recommended Posts

I need to start LINDA for my NGX Mode togglesMode 1 cfg's are loaded, but cannot toggle to Mode2 without LINDA actually started upthis Normal behaviour?(seems unexpected, why would this be?)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you ask if LINDA is working, when LINDA is not started?LINDA have to run to work according to the manual ...

Share this post


Link to post
Share on other sites
Do you ask if LINDA is working, when LINDA is not started?
yes, well it will work always, but only the Mode1 part
LINDA have to run to work according to the manual ...
yes, figured that out allreaybutLINDA actions.lua (is prob what it is) Mode1 definitions now allready work without loading LINDA (.exe?)sowishlist ..LINDA core runtime that makes MODE1/2/3 toggle possible without having to load the interface(Its more elegant programing?)thanx, btw, great program

Share this post


Link to post
Share on other sites

no, sorry, that is definitley not possible.What is the problem to have LINDA running?

Share this post


Link to post
Share on other sites
What is the problem to have LINDA running?
we dont need the whole interface for flyingwe just need the definitions (inc. working mode1/2/3 toggle)(EDIT: like for instance Ultimate Traffic 2:there's an interface for the setup, and a runtime ulimateservices.exe loaded with exe.xml (it think, not at my box) that actually runs the traffic in FSX)

Share this post


Link to post
Share on other sites
we dont need the whole interface for flying
not the interface, but LINDA itself.After opening the Interface (better said LINDA) you can send it to taskbar if not needed (could be done automatically in settings).so I do not see the point to have a non-interface-Linda.exe in the taskbar minimized or a LINDA-with-interface.exe there ...But with all discussing: currently I see no chance that this would be changed ...

Share this post


Link to post
Share on other sites

LINDA needs to be running for most of the joystick button features to work, this is not going to change. Artem went through extensive prototyping during alpha testing and the current method requiring LINDA to be running at all times was the most reliable and effective.

Share this post


Link to post
Share on other sites

If you mean MCP Combo modes, buttons and so on, then you DON'T need LINDA GUI (exe) kept running.It's required ONLY for joystick assignments to operate, and Andy is right - this will not gonna change in future, because of FSUIPC HID-library limitations.

Share this post


Link to post
Share on other sites