Sign in to follow this  
Followers 0
pschlute

A story about FS9 CTD

12 posts in this topic

Just thought I would post this as an example of how problems in FS9 are not always what they first appear. Hopefully it will help others in future.I recently downloaded FSDreamTeam KLAX. Ran the installer and went to KLAX to have a look. I lasted less than a minute before I got the Crash to Desktop. I had already disabled the previous AFCAD I was using for the default KLAX so I knew that wasnt the problem. I uninstalled KLAX and reactivated the old AFCAD. Went to the same location at the same time...and CTD with default scenery. I now suspected an AI texture, and turning off the AI aircraft confirmed the fact.So with AI switched on again I went to various locations at KLAX so I cound use spot view and Ctrl-W to identify the culprit. I would get the CTD when I cycled through to a EMB 190 in Frontier colours, so I replaced those textures but made no difference. I then suspected a Delta 757 but that was fruitless too. By zooming in very close in the spot view cycling I now would only get the crash when a 737 winglet model was in frame. Unfortunately I have 737-300/500/700//800/900 winglet aircraft at KLAX.By removing the aircraft folders one by one I knew a 735 was the culprit, and I only have one 735 visitor to KLAX, a United texture I downloaded about 4 months ago. I couldnt see anything wrong with the texture but swapping it for a different one solved the CTD,So reinstalled the FSDreamteam KLAX and all is well.Peter

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Goof to know Peter, thanks for the heads up, do you remember the offending file and the one you replaced it with?Thanks again for sharing,-Paul

0

Share this post


Link to post
Share on other sites

PaulI have done a quick search in the library and cannot find the repaint that was causing me problems. It was a United Star Alliance winglet. Could I suppose have just been a corrupt download.Peter

0

Share this post


Link to post
Share on other sites

I wish there's a program or process that could detect corrupt textures, a bit like ACA 2005 which can detect problems with AI traffic. Right now it's all trial and error.

0

Share this post


Link to post
Share on other sites

I use the free version of FSRepaint to check all my textures after installing. Very handy tool , not having to go into FS9 and find the actual plane to see if it works.However in this case the offending texture displayed correctly in FSRepaint, just didnt work in my setup in FS9.Peter

0

Share this post


Link to post
Share on other sites

Very interesting. And an excellent bit of detective work. :( I have always wondered what must be corrupt about a file for FS to crash.

Edited by speedbird2001
0

Share this post


Link to post
Share on other sites

If you have installed 32-bit textures, many times these are the culprit. Using a 32-bit texture itself will not cause the issue, but if the painter saves the texture directly from a program like Photoshop and uploads that file as 32-bit, it will not display properly and WILL crash the sim. What has to be done is that once the painter saves his texture as 32-bit from the graphics program, he MUST run it through either Imagetool or DXTBMP to convert it to a usable 32-bit format (or DXT3). I am not entirely sure why this is, but there must be a slight difference in the 32-bit formats used in the sim and by the painting programs. Important to note that looking at a 32-bit texture in either ACM or FSRepaint will NOT tell you if this is a problem...

0

Share this post


Link to post
Share on other sites

Grrrr...Spent another hour troubleshooting because of a corrupt texture.Started at Frankfurt EDDF - when I pan the spot view camera FS9 crashes G2D.dll CTDTried again, freezesTried Default C172, freezes againChecked AFCAD is OK, freezes againDisabled AI traffic, FS9 runs fine, Enabled AI Traffic, FS9 Freezes with a black screenTried again and pans VC Camera around airport. Noticed FS9 freezes when the cargo apron is in view.Took another look at the Cargo apron without AI traffic. Ran Procmon. Enabled AI traffic. FS9 Crashes. Procmon doesn't show anything unusual. Noticed an untextured aircraft when FS9 Crashed. Looked like an A300.Removed TFS A300 from the aircraft folder. FS9 Still freezesHad another look at the cargo apron. This time I could confirm the untextured aircraft is a MD-11 or MD-10 or DC-10.Removed Globusworld's MD-11. FS9 ran fine.Edited Globusworld's MD-11 air file to make it visible. Ran FS9 and went into "Select aircraft". FS9 freezes when Lufthansa Cargo D-ALCJ selected.Opened imgtool. open the D-ALCJ textures and saved.Ran FS9. No more problems at EDDF.

0

Share this post


Link to post
Share on other sites

George and IainThanks very much for that advice. I had replaced my Lufthansa Cargo MD11 textures recently with GW models. Guess what.... visit EDDF and CTD !Followed your advice re. imgetool and works a treat. It seems my original post to help others has ended up helping me.Thanks againPeter

0

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0