Jump to content

Archived

This topic is now archived and is closed to further replies.

phmcr

FSX not writing to FSX.CFG

Recommended Posts

Hi,

 

I have a clean install of FSX on a new W8 machine.

It runs nicely.

But, after changing some values in the fsx.cfg and when I start FSX I immediately get the message FSX cannot write to the FSX.CFG file (which I have just changed) and stops. I never had this problem before and obviously it has to do with Administrator rights. But I am the only user and hence I AM the Administrator.

As far as I can see, the file's security settings are ok, but 1 out of 2 times FSX cannot write and the only solution is to copy a backup copy back into the appropriate directory.

Any ideas how to prevent these lock-ups?

 

Thanks,

Menno

Share this post


Link to post
Share on other sites

Have you set Fsx.exe to run as an administrator?

Ie Properties\compatibility\run as an administrator\apply.

While you are there, it might help to set "run this program in compatibility

mode for:" to Windows 7.

 

Windows 8 seems to require all third party software to be installed and

run as an administrator and if this is done, in my experience, works perfectly well.

 

Also, do not install anything third party into C:\Program flies and if you can avoid it,

C:\Program files (86).

 

FSX is much better in its own folder and ideally on a separate drive from the OS.

Share this post


Link to post
Share on other sites

Hi, yes, I have properties set as you mention. But still......

Share this post


Link to post
Share on other sites

Hi Menno:

 

Download and run this file: it is called "Take Ownership". It will add an option to the "Rt-Click" menu (which pops up when you Rt-click on any file), allowing you to take ownership of that file or folder. Provided it's not complicated by being a folder inside the ProgramFiles, or ProgramFiles(x86) folders, you can use it to give you complete control over almost any file or folder.

Share this post


Link to post
Share on other sites

Hey I had same problem when i was tryig to replace the fsx.cfg file with this one tweeked using this tool http://www.venetubo.com/fsx.html.....the problem is when you downlaod this modified cfg the OS know that is not from your PC not created on your pc and so it blocks it and it won run it. You can see that when you right click on it and look at that window under securityv tab(I thin so) on the bottom there is some tick box about that you allow to run this even if it is not from your PC...or something like this...go ahead and check your cfg if it has soemthing like this in its propreties window...if it does have or doesnt try following...this two steps fixed problem in my case....1) go to C:\Users\your user name\AppData\Roaming\Microsoft look there for FSX folder right click propreties/security tab/edit/ and thick Full Control box For all User names or grups that you see on that list now apply those changes this step do also for your root FSX instalation folder....2)now navigate to your FSX.cfg file open it in notepad select all/copy then close it and delete the cfg file the in the same folder create same file with same file type and same name and paste in it the lines that you hava copied before..and save changes...now it should work in my case it worked..

Share this post


Link to post
Share on other sites

Thanks Guys, appreciate the help.

Paul, that tool comes in handy for other problems I have.

Nice, indeed it was a copy of the file from Venetubo. I copied its contents into a freshly made file by FSX after I had deleted the former one.

 

Menno

Share this post


Link to post
Share on other sites

×
×
  • Create New...