Archived

This topic is now archived and is closed to further replies.

1Wolf

Black Squares for VASI Lights?

Recommended Posts

Every once in a while I get this odd thing where when I look at a runway off in the distance, where the VASI lights are I get black squares for the VASI lights instead of the actual lights. This doesn't happen all the time and there doesn't seem to be any rhyme or reason to it. Sometimes it happens in congested areas and sometimes it happens out in the middle of nowhere. When it happens, its only for a second. I use TrackIR and if I happen to look out in the distance I "may" see those black squares in place of a runway's VASI lights. In just a second, the squares will go away and the correct VASI lights will be shown. If I look away, and then look back, they'll be fine. However, if I've been looking away for a while (a few minutes maybe) and then look back again...they might briefly (for a second or less) turn into black squares again.

 

I've done a bunch of searches and the common consensus seems to be the ever-popular "Turn your sliders down". But I think there is more to it then that. Obviously, almost anything can be fixed by turning your sliders down. Thats kind of like the old joke of someone going to the doctor and saying "Doc...it hurts when I move my arm this way" and the doctor responding "Then don't move your arm that way" ;)

 

My system is pretty high end, although its not overclocked at this point. I haven't had a need to so far. Back before I added any FSX AddOns when my FSX install was completely default with modest slider settings..and flying out in the middle of Illinois farmland with very little around...I would still get this thing. Sometimes I'd get it ALOT....sometimes I wouldn't. Currently, my system is setup per Word Not Allowed's guide, sliders are set higher (Pretty close to Word Not Allowed's settings), and I'm running UTX/GEX/REX Textures....I still get the problem. I don't seem to get it any more or any less than I did with a complete default install.

 

It also doesn't seem to be related to congestion...whether I'm flying over Seattle with ORBX PNW or Illinois farmland...sometimes it happens...sometimes it doesn't.

 

I run locked at 30 FPS and usually my FPS hovers right around there. It dips into the mid-to-low-twenties occassionally in urban areas. It happens with the same, random frequency

 

Also, I'm not sure if its related or not...but every once in a while I'll get a square of regular scenery that will appear black for just a quarter second or so...then quickly repaint with the correct texture as I look at it. This happens pretty rarely, and pretty randomly.

 

I'm guessing that there is some setting in fsx.cfg that tweaks this and thats what I'm missing. Its really not THAT big a deal as they only stay black for less than a second....but I'm just curious to fix it. If its just adding a setting to my fsx.cfg or some such....then I figured I'd give it a shot :)

 

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I see this sometimes too. My guess is that the system has not caught up enough to load all bitmaps necessary to render the scene. It's like lights are loaded last or something. I see it on VASI lights or on external views of my plane on the nav lights or landing lights, but only for a brief second, then they pop in. I have not figured out how to stop it but it is a minor annoyance to me and I have not persued a solution.

Share this post


Link to post
Share on other sites

When light sources come into range, such as VASI on a runway or another aircraft's lights in the sky, I get a momentary black "square", then the correct light. Is it possible that you are forcing your FSX to have a too-large visual radius?

 

Thanks, Bruce.

Share this post


Link to post
Share on other sites

I've seen the black squares pop up, then quickly replaced by the correct texture since day 1 with FSX. It just takes time for FSX to load these textures and the more intensive the scenery, the longer it takes.

Share this post


Link to post
Share on other sites

Well....at least I know its not just me.

 

Thanks guys. Sooner or later hopefully someone will stumble upon some setting or some tweak to fix it. I noticed it does seem 'worse' if I lower my FTFF down to .20. At the default .33 there does seem like it happens less often, and is less intrusive when it does.

Share this post


Link to post
Share on other sites