Archived

This topic is now archived and is closed to further replies.

nhenley85

Carenado and DX10

Recommended Posts

Would someone please tell me how I can make my new Carenado Addons stop crashing my sim. The older Carenado stuff (the Mooney 201, C182RG, C182Q, C206, F33A, V35B, Arrow IV, Archer II, Cherokee 180, and C152) works great, but the new stuff (C182T, B200, C337, C340, B58, A36, C90, TBM850) crashes. I use DX10 Preview mode because I love the performance increase. The Addons work great, but in DX10 mode they cause my screen to go blank and then freeze my sim shortly after. I have an awesome PC but as we all know, FSX doesn't deliver the best performance. I'm currently using Windows7 64bit. I have a 3gig processor, 9gigs of RAM and 4gigs of video RAM. I don't want to give up the performance I get with DX10 Preview though. Would someone please help me make my sim work and look correctly in DX10 mode? Also I am using REX and UTX for enhanced flight environment. I know it is possible to make this happen, Eaglesoft's CJ-1 v2.0 is DX10 Preview certified, so it can be done. Is it something in the "aircraft.cfg" file? I'm not sure but I think the .cfg file is mostly aircraft performance... Somebody help me!!! Lol

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "DX-10 Discussions, Hints and Help". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post

Hi nhenley! Welcome to the DX10 Club!!!  :lol:

 

At the top of this forum there are a few pointers and links to various places, but the first stop is to download the "How-To" guide - (either a Word doc or a pdf) and do some studying for an hour or so. There are a lot of things that can be changed, and there's a lot of good folks here who will be glad to do some hand-holding until you get your feet good and wet - OK!

 

All the Best,

Share this post


Link to post

I own many of the Carenado addons (old and new) and have never suffered a crash with DX10 Preview enabled.  I think your problem(s) are not related to DX10 but something else in your installation.  You should download and run AppCrashView - http://www.nirsoft.net/utils/app_crash_view.html and copy and paste the results of your latest crash here for analysis.  Most likely you have high FSX or display driver settings and your computer cannot handle the rendering of Carenardo aircraft with these high settings.  High settings also include your settings in REX and UTX has been known to bring down computer systems depending on what you have enabled in UTX and whether the enabled settings are set to max or not.  Hope this helps. 

 

Best regards,

Jim

Share this post


Link to post

Ok, let me make sure I understand... I can fix this issue by working with my FSX display settings? That makes since. Some of the less detailed addons never crash. Ill play with it a little tomorrow and let you know how it turns out. Ill leave the thread up just incase. Oh, one more thing, when in DX10 Preview mode, some of my addons textures do not show up. Is there a way to correct this? Also on the DX10 subject, is there a way to get rid of the good ole runway flicker? And, is there a way to fix the aircraft and airport lighting?

Share this post


Link to post

There is a fine flicker fix that also takes care of other anomilies somewhere in the library here.

Share this post


Link to post

Ok, let me make sure I understand... I can fix this issue by working with my FSX display settings? That makes since. Some of the less detailed addons never crash. Ill play with it a little tomorrow and let you know how it turns out. Ill leave the thread up just incase. Oh, one more thing, when in DX10 Preview mode, some of my addons textures do not show up. Is there a way to correct this? Also on the DX10 subject, is there a way to get rid of the good ole runway flicker? And, is there a way to fix the aircraft and airport lighting?

I rarely see these issues so, yes, these can be corrected.  If some of your addons do not show up, perhaps they were developed for FS9 and earlier versions of FS?  Also, make sure you have the highmemfix=1 fix (not a tweak) line in the Graphics section of your fsx.cfg.  I have my Nvidia NI settings set to the Nvidia default for FSX (same in the display driver settings in case you do not have the NvidiaInspector program).  They clamp the Negative LOD bias line which is known to take care of stuttering and flickering for the most part.  It does not totally eliminate it though.  There are a lot of suggestions for fixing airport and aircraft lighting in this forum and in the How To guide pinned at the top of this forum.

 

Just don't turn your settings up too high.  If you do, fsx will have difficulties rendering or processing everything you are trying to throw at it (that's my secret for success).

 

Best regards,

Jim

Share this post


Link to post

Once again - I suggest that you read and absorb the guide, and then as many of the posts in this forum as you can. 

Share this post


Link to post

Thanks so much for all your help guys. My sim is finally looking and performing like I always wanted :h

Share this post


Link to post

I hate asking dumb questions but where do I find my FSX.cfg file??

Share this post


Link to post

I added the highmemfix=1 line to the FSX.cfg and it did nothing. The addon planes that have the issues were made for FSX and I'm still having the flicker and the aircraft and runway lights problem... Sorry guys, I've been out of the flightsim game for a long time and most of what I know is aircraft editing and that knowledge is limited. You guys have to dumb some of this stuff down for me lol. What do I try now?

 

The line I posted that said everything is working was supposed to go in a different forum for a different sim, sorry about that. Everything in FSX is still happening. Not crashing in DX10 anymore when using the new Carenado planes but still having issues with textures on some other planes and with the runway and aircraft lights, and with the flicker

 

Sorry everyone, just frustrated...

Share this post


Link to post

I am happy to say that all but one problem has been fixed. The sim hasn't crashed at all since I applied everyone's advice and the only problem left is the textures not showing up on a few aircraft. Hopefully something can be done about this. The addons in question are developed for FSX but the textures just won't show. Unfortunately, they are some of my favorites to fly :(

 

And final ideas?

Share this post


Link to post

Like PaulJ said, you should look at his How to guide and also his AVSIM Software and Hardware Guide.  Did you see in the How To guide about runway light fixes?  There is also a neat utility that you can test as freeware and purchase if it works.  It's called Addon_Converter_X and you can download it and run it in demo mode for 10 minutes at a time to see if it fixes your issue.  It converts old FS9 textures to be compatible with FSX.  It does it on the fly though and does not save the textures.  I think the cost of the utility is 20 bucks if you decide to purchase.

 

The highmemfix=1 line in the Graphics section of your FSX.cfg does not fix all textures disappearing.  If you have FS9 textures and you are using DX10, then the FS9 textures will not show up no matter what.  It is an important fix for FSX as there are other anomalies you'll run into if it is not activated (i.e., =1). 

 

If you look on the first page of the How To document, it will tell you about Steve's fix for runway and taxiway flashing.  It was fixed in the first release of Steve's DX10 Fix.  There's a new release (3.2.2) which has these fixes plus there is a bonus section for fixing DX10 lights.  It is possible that your install of Steve's DX10 fix did not make the changes it was suppose to do.  You can look in Microsoft Flight Simulator X\ShadersHLSL\General folder.  The only file that was changed was General10.fxh.  it should have saved your orig to General10.fx.ORIG.  If it did not happen, then you have not properly installed the fix.

 

Hope this helps.

Share this post


Link to post