Jump to content

Archived

This topic is now archived and is closed to further replies.

jimh

Terrain.dll Problem

Recommended Posts

Hi,

I don't suppose this is a DX10 problem, but I could sure use a hint or some help.

Last time I posted, I was reinstalling FSX etc., after a flirtation with SweetFX.

I've been flying only in UK and Europe, lately, so installed FSG Ultimate, GEX/EU, UT/EU, FTX England and Wales, UK2000 Airports, and photo scenery for Scotland.  So far all ok.

 

I had trouble installing Alderney from Earth Simulations, and getting it to appear in FSX.  It appeared to be an "uninstalling" problem, so I removed all entries for ES in the registry.  I reinstalled Alderney, and checked that all was well in a short flight  over the island.  All ok so far.

 

I then installed Guernsey, the Scillies, and Treescapes 4. 5, 6, and 8.

 

FSX will now load up to 70%, and crash out with a Terrain.dll error in the Event Log.  I've tried disabling ES, uninstalling ES, and copying terrain.dll from a backup, all with the same result.  FSX will start up, and load scenery to 71%, then crash out.

 

Sorry about the long description, but these are the details.  I hope someone can help.

 

Hopefully, Jim

 


Asus Rog Maximus VIII Hero, i9-10900k 4.8GHZ, Corsair H100 cooler, 32GB Corsair Vengeance 2666, RTX3090 20GB, Win10 HP 64-bit, 3 Monitors "19-22-19", HP Reverb G2 Headset.

Share this post


Link to post

Disable all the addon scenery in the Scenery Library that you added.  Run FSX.  If the problem still exists, then you might have a problem with your FSX.cfg.  If no problems, then start enabling any addon scenery 2-3 at a time until the problem reoccurs.  There could also be a problem with your install of UT/EU but that will be discovered if you disable it in the Scenery Library as I discussed.

 

Best regards,

Jim


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

Thanks, Jim.

 

I've tried your advice, but no luck.  I've allowed FSX to make a new cfg, but no difference.

 

Loading a flight, default flight, any flight, stops at 71%.  I've been able to see very briefly, that i'ts trying to load/read Autogen.

 

I've now replaced the entire contents of FSX\Autogen, with those of a True Image backup.

 

Still using the new basic fsx.cfg, I can now get into a flight.  I'll now try to work back step by step.

 

Thanks again for your help.

 

Best, Jim


Asus Rog Maximus VIII Hero, i9-10900k 4.8GHZ, Corsair H100 cooler, 32GB Corsair Vengeance 2666, RTX3090 20GB, Win10 HP 64-bit, 3 Monitors "19-22-19", HP Reverb G2 Headset.

Share this post


Link to post

have you tried to put in a fsx cd again and choose for repair.

sometimes it helps , it takes away some errors.


paula

Share this post


Link to post

Thanks, Paula.

I've never tried a repair from an FSX CD.  I'll remember that option.

 

I think I'm ok now.  I was focused on Terrain.dll, until I got a glimpse of "loading autogen" or something similar.  Replacing the contents of FSX\Autogen seems to have solved the problem.

 

I'm now on my normal fsx.cfg, and have re-enabled all my addons except ES, test flying along the way.

 

Right now I am backing up my FSX drive, having backed up a parallel C drive.

 

Regards, Jim


Asus Rog Maximus VIII Hero, i9-10900k 4.8GHZ, Corsair H100 cooler, 32GB Corsair Vengeance 2666, RTX3090 20GB, Win10 HP 64-bit, 3 Monitors "19-22-19", HP Reverb G2 Headset.

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    49%
    $12,400.00 of $25,000.00 Donate Now
×
×
  • Create New...