Archived

This topic is now archived and is closed to further replies.

db.flightsim

FSX Won't Install on Windows 8

Recommended Posts

I tried posting on the MS support forum but had no luck. I also posted on flightsim.com and was advised to ask here.

I have run FSX (Flight Simulator X) on my old Windows 7 machine for several years but have now upgraded to a new Windows 8 PC. However, when I try installing FSX from the disk, it gets to the end of the installation, generates a 1722 error code, rolls back the installation and displays a 1603 error. I have tried this on both machines and running the installation in several compatibility modes but I keep getting the same issue. I tried to copy the installation from my old PC to my new one but the game wouldn't load. I have also tried clearing my registry and installing it but that hasn't worked. Is there anything else I can do? It is FSX Gold edition if that helps? I have also attached a screenshot of the error message.

 

Post on flightsim can be found here.

Post on MS support forum (none of their suggestions worked) can be found here.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Are you trying to install to the default path? If so, don't do that...

 

Use the Custom install option and create your own, shorter path such as C:\FSX for the installation. This will keep FSX from the overly protected areas of the operating system.

 

Also, right click on the installation program and run it in Administrator mode.

Share this post


Link to post
Share on other sites

You want to make sure everything in FSX is uninstalled before installing.  There are a lot of folders left over when you uninstalled FSX.  Run a registry cleaner and make sure fsx is removed from the hidden folders. 

 

Can't believe AVSIM was your third choice....  :lol:

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

I have fsx(download version) installed to default path on Win8 64bit with no issues/crashes in over 6months.  I'm actually in shock that I can't get FSX to crash on my PC :lol:   it's stable like a rock :lol:

Share this post


Link to post
Share on other sites

You want to make sure everything in FSX is uninstalled before installing.  There are a lot of folders left over when you uninstalled FSX.  Run a registry cleaner and make sure fsx is removed from the hidden folders. 

 

Can't believe AVSIM was your third choice....  :lol:

 

Best regards,

Jim

Lol, I was having some trouble getting my account set-up so had to go elsewhere

Share this post


Link to post
Share on other sites

Are you trying to install to the default path? If so, don't do that...

 

Use the Custom install option and create your own, shorter path such as C:\FSX for the installation. This will keep FSX from the overly protected areas of the operating system.

 

Also, right click on the installation program and run it in Administrator mode.

I've tried this but still had the same issue.

Share this post


Link to post
Share on other sites