Jump to content

Archived

This topic is now archived and is closed to further replies.

Tristan

FSX crashes running on Windows 8 64bit

Recommended Posts

Hi there,

 

I've recently bought a ASUS notebook with WIndows 8 64bit. My graphics card is Nvidia GEFORCE GT 650M, CPU Intel Core 17 2.4Hz, 8GB or Memory, DirectX11. I basically bought this notebook to run FSX and add-on aircraft mainly PMDG. Well FSX and my notebook don't seem to agree, after maybe a couple of minutes, FSX will stop working, I will still hear the sounds coming from FSX but the screen will be blank. I occasionally get a message saying "Display driver stopped responding and has recovered: Display driver NVIDIA Windows Kernel Mode Driver, Version 314.22 stopped responding and has successfully recovered." There was a period when FSX was running fine, but these problems return.

Other times, the screen will go blank and I get a message saying "FSX is not responding."

 

Many thanks

 

Tristan

 

Share this post


Link to post
Share on other sites

I would first install the nvidia drivers again (as admin).

Did you install fsx outside the program files hirearchy,and as admin?

Share this post


Link to post
Share on other sites

Hi Jude,

 

Not sure exactly if installed FSX as admin, but I do remember installing it express (recommended)  as per the software options.

 

Tristan

Share this post


Link to post
Share on other sites

Your display drivers are not installed properly or you tried to overclock the video card or the video card is overheating.  I can successfully get that error 100% of the time if I try overclocking my video card.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Express install would install it in the programfiles folder.

Ensure that FSX is running with admin privileges (right-click on FSX.exe and select Run as admin).

and update your video card drivers.

Share this post


Link to post
Share on other sites

Thanks,

 

I've been opening FSX through the 'START' page and running it as administrator. I haven't had any big problems, the occasional crash, but so far seems ok.

Share this post


Link to post
Share on other sites

If you navigate to the FSX folder, right-click on it,select 'Properties', click on the 'Compatibility' tab,

Check 'Run this program as administrator' in the check box,and 'Change settings for all users' it should

be able to be run with the desktop icon.

Share this post


Link to post
Share on other sites

×
×
  • Create New...