Jump to content

Archived

This topic is now archived and is closed to further replies.

Faisal altheyab

SimConnect help Please

Recommended Posts

Hello

i have no idea why i even thought of trying simconnect .haha. 

my journey started with installing simconnect using this guide http://www.fsdeveloper.com/wiki/index.php?title=SDK_Installation_%28FSX%29 i followed the part where it says ( FSX Acceleration Pack users about 3/4 down the page) and it states to first install the sdk from the deluxe disk 1 then to install sp1a that comes with the  acceleration disk then to install the main acceleration sdk ( so no sp2 ) and then i continued to configure my simconnect .ini and .xml and .cfg BUT when i first tried to open fsx and run AI traffic on my client computer there was no connection ( By the way fsx is on my E drive and i installed the sdk's on my C drive ) . i tried multiple times of changing the files but i didnt end up with anything working so please i would very much like for someone to help me with this problem.  ^_^ 

 

My ip address for the main computer : 192.168.100.50

port numer : 4506

 

My .XML file that is in /roaming/Microsoft/fsx

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>
   <Disabled>False</Disabled>
   <SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>IPv4</Protocol>
<Scope>link-local</Scope>
<Address>192.168.100.50</Address>
<Port>4506</Port>
<MaxClients>10</MaxClients>
<MaxRecvSize>4096</MaxRecvSize>
        <DisableNagle>False</DisableNagle>
</SimConnect.Comm>
 
<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>IPv4</Protocol>
<Scope>global</Scope>
</SimConnect.Comm>
</SimBase.Document>

 

 

My .INI file that is in Flight simulator x files : 

 

 

[simConnect]
level=verbose
console=1
;RedirectStdOutToConsole=1
;OutputDebugString=1
;file=c:\simconnect%03u.log
;file_next_index=0
;file_max_index=9
 
 
And my .cfg file that is in my client computer : 
 
 
[simConnect]
Protocol=IPv4
Address=192.168.100.50
Port=4506
MaxReceiveSize=4096
DisableNagle=0
 
THANK YOU  ^_^
 
 

 

 

 

 

Share this post


Link to post
Share on other sites

First of all. What are you trying to accomplish? Your Simconnect.xml syntax looks a little funny? Also, you run the AI traffic on the server/FSX computer to make sure its communicating with simconnect to begin with before you get into the network comms..

 

<?xml version="1.0" encoding="windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>
   <Disabled>False</Disabled>
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>192.168.0.4</Address>
      <MaxClients>64</MaxClients>
      <Port>500</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>192.168.0.4</Address>
      <MaxClients>64</MaxClients>
      <Port>6811</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>192.168.0.4</Address>
      <MaxClients>64</MaxClients>
      <Port>23000</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>

<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>Auto</Protocol>
<Scope>local</Scope>
</SimConnect.Comm>
</SimBase.Document>
 

Share this post


Link to post
Share on other sites

Make sure the port used for simconnect is opened in your anti-virus or firewall. Also, if on a wireless network, your router software is configured to keep the port open. I would post the samples of my file but I'm currently not at my fax computer!

And also have you run simconnect.msi supplied in the sdk folder on the client computer?

Share this post


Link to post
Share on other sites

You also have to have all the sharings set up correctly for the network part but first you must make sure simconnect is operating properly on the server/FSX computer. That is what running the ini, console=1, Ai traffic is for. the great folks at Active Sky/Hi Fi Sim, put together an excellent tutorial for simconnect. I have 3 or 4 apps on various computers running Simconnect and I use the ASE/2012 tutorial for all of them.

 

If you are unable to get things working properly with FSX/P3D and Simconnect, please check for the following common issues:
 Standard networking not properly configured between computers
 SimConnect.xml, SimConnect.ini and/or SimConnect.cfg not properly existing or configured properly and in the proper locations
 Port not enabled via software firewalls
 Improper computer name or ip address set in the Address fields of the .xml and .cfg files
 Protocol not set for IPv4 in .xml and/or .cfg files
 SimConnect.msi installer not run on client machine

Share this post


Link to post
Share on other sites

You also have to have all the sharings set up correctly for the network part but first you must make sure simconnect is operating properly on the server/FSX computer. That is what running the ini, console=1, Ai traffic is for.

 

hello what im trying to accomplish is to use simconnect on my 2nd computer so i can run applications like : active sky 2012 on it . sorry my mistake i use to think that i must run the ai traffic on my Client Not the main pc i will try to change my .xml file but do you want me to copy yours and put mi ip and port in it or what 

Share this post


Link to post
Share on other sites

You also have to have all the sharings set up correctly for the network part but first you must make sure simconnect is operating properly on the server/FSX computer. That is what running the ini, console=1, Ai traffic is for. the great folks at Active Sky/Hi Fi Sim, put together an excellent tutorial for simconnect. I have 3 or 4 apps on various computers running Simconnect and I use the ASE/2012 tutorial for all of them.

 

If you are unable to get things working properly with FSX/P3D and Simconnect, please check for the following common issues:

 Standard networking not properly configured between computers

 SimConnect.xml, SimConnect.ini and/or SimConnect.cfg not properly existing or configured properly and in the proper locations

 Port not enabled via software firewalls

 Improper computer name or ip address set in the Address fields of the .xml and .cfg files

 Protocol not set for IPv4 in .xml and/or .cfg files

 SimConnect.msi installer not run on client machine

hello 

thank you i have tried yours and it worked the ai traffic application gave me a connected sign i used you .xml 

thanks you . you surely made my day  :lol:

Share this post


Link to post
Share on other sites

Out of curiosity.. What AI traffic application are you running that requires SimConnect?

 

Thanks,

Ernie

Share this post


Link to post
Share on other sites

Out of curiosity.. What AI traffic application are you running that requires SimConnect?

 

Thanks,

Ernie

It is an AI application in the FSX SDK for programmers..

Share this post


Link to post
Share on other sites

Thanks..

 

I've run a copuld of the SDK applications such traffic toolbox, but they only required having their information inserted into dll.xml.

 

I guess that I need to take a closer look at the SDK.

 

Ernie

Share this post


Link to post
Share on other sites

×
×
  • Create New...