Archived

This topic is now archived and is closed to further replies.

SkipNL

Saitek Proflight Yoke; strange screen (resolution) problem

Recommended Posts

Hi Everyone

 

I have a strange problem with my new Yoke + Throttle.

 

Everything works fine. Until I enter fullscreen or maximalised window. 

When I do that, the yoke controls freeze and come back to life only when I plug and unplug the yoke and restart FS9. This is also visible in the driver calibration dialog.

 

Windows, Bios, drivers, etc. are up to date.

 

To add to the strange behavior, when I enter another user account on the computer (one that hasn't used FS9) the problems seemed nonexistent at first. I was able to fly for an hour or two. When I was confident the problems were somehow linked to the other account I started to customize the settings on this new account. 

 

And then the problems started occuring in the other user account as well.

As soon as I put graphics settings on 'High' and increased screen resolution from 800x600 to a higher resolution the problem was suddenly back.

 

Does anyone have advice?

Or a fix?

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What version of Windows are you using? There are a lot of problems with Windows 8 and HID controllers--there is a lot written about this in the Windows 8 forum. In Win Vista/7/8 you want to make sure that the "allow windows to shut down this device to save power" or similar option is NOT checked in the device manager.

 

Regards

Share this post


Link to post
Share on other sites

Check the AVSim Windows 8 forum and look at the Joystick Megathread. The solution is to use either an app such as Linda or an add on such as FSUIPC that controls the yoke/joystick independently of FSX or P3d.

Share this post


Link to post
Share on other sites