Sign in to follow this  
MarkDH

Can I tune radios manually?

Recommended Posts

If I have the ATC window open and tune a radio manually, I find the copilot then says 'setting com1 to' and then the radio digits get entered as ATC menu selections, one after the other. For example, 122.95 negotiates the ATC menus as if I had pressed the keys 1, 2, 2, 9, 5. Obviously this messes things up and I end up with ATC thinking I am making an approach to some random nearby airport.

 

What am I doing wrong?!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If I have the ATC window open and tune a radio manually, I find the copilot then says 'setting com1 to' and then the radio digits get entered as ATC menu selections, one after the other. For example, 122.95 negotiates the ATC menus as if I had pressed the keys 1, 2, 2, 9, 5. Obviously this messes things up and I end up with ATC thinking I am making an approach to some random nearby airport.

 

What am I doing wrong?!

 

You can prevent FO interfering with radios as follows.

 

Go to <ATC> tab of the user interface and un-tick option Co-pilot can handle radio if busy, and don't tell him "You have the radios". If you do by accident, just tell him "I have the radio".

Share this post


Link to post
Share on other sites

You can prevent FO interfering with radios as follows.

 

Go to <ATC> tab of the user interface and un-tick option Co-pilot can handle radio if busy, and don't tell him "You have the radios". If you do by accident, just tell him "I have the radio".

 

Sorry, that doesn't make sense. Regardless, it makes no difference. (Okay, it makes a small difference: the co-pilot no longer says 'switching to' (or whatever it was), but the spurious keystrokes still get played and I still end up in some random state.)

 

You understand that I am tuning the radios by changing the frequency using a hardware panel?

Share this post


Link to post
Share on other sites

Sorry, that doesn't make sense. Regardless, it makes no difference. (Okay, it makes a small difference: the co-pilot no longer says 'switching to' (or whatever it was), but the spurious keystrokes still get played and I still end up in some random state.)

 

You understand that I am tuning the radios by changing the frequency using a hardware panel?

 

Not sure if you are aware, there is a built-in feature that goes like this...

 

Assumng you are on a VFR flight....

 

Every time you dial or swap freq on COM 1, the software will be monitoring.

 

By default if you stop dialling for more than 3 seconds it will assume you have dialled the intended frequency.

 

It will then proceed to automatically go through the various FSX (P3D or FS9) ATC menu and connect you straight to the intended station, without you having to select <Nearest airport list>, scroll through 2 or 3 pages of airports before settling for one and finally contacting tower.

 

You can disable that behaviour as follows.

 

Open "mce.ini" found under C:\Users\your_user_name\AppData\Roaming\Multi Crew Experience\ folder

 

Look at the [Go-FLIGHT] section

 

Change "Use=1" to "Use=0"

 

Save the file.

 

Monitoring will stop after that.

Share this post


Link to post
Share on other sites

Which panel are you using to change frequencies ?  The Saitek and GoFlight radio panels work fine with MCE using

 

[Go-FLIGHT]

Use =1

 

in mce.ini file. MCE monitors those as described above.

 

Not sure about other hardware. If you just use e.g. a numeric keypad I'm guessing it will interpret the keystrokes separately and just select the ATC options as you describe.

Share this post


Link to post
Share on other sites

Not sure if you are aware, there is a built-in feature that goes like this...

 

Assumng you are on a VFR flight....

 

Every time you dial or swap freq on COM 1, the software will be monitoring.

 

By default if you stop dialling for more than 3 seconds it will assume you have dialled the intended frequency.

 

It will then proceed to automatically go through the various FSX (P3D or FS9) ATC menu and connect you straight to the intended station, without you having to select <Nearest airport list>, scroll through 2 or 3 pages of airports before settling for one and finally contacting tower.

 

You can disable that behaviour as follows.

 

Open "mce.ini" found under C:\Users\your_user_name\AppData\Roaming\Multi Crew Experience\ folder

 

Look at the [Go-FLIGHT] section

 

Change "Use=1" to "Use=0"

 

Save the file.

 

Monitoring will stop after that.

 

Thanks, that stopped the spurious keystrokes. I still get the FO talking ('radio switched to approach', etc.) - can I get rid of that?

Which panel are you using to change frequencies ?

 

Should that make a difference? I'm using an Elite AP-4000 COM/NAV radio.

Share this post


Link to post
Share on other sites

Should that make a difference? I'm using an Elite AP-4000 COM/NAV radio.

Sorry - just checking whether you were using a pukka radio panel or something else. It sounds like the Elite panel works differently to the GoFlight and Saitek panels though.

Edited by DickB

Share this post


Link to post
Share on other sites

Sorry - just checking whether you were using a pukka radio panel or something else. It sounds like the Elite panel works differently to the GoFlight and Saitek panels though.

 

Actually the Elite driver uses FSUIPC, like Saitek (or Saitek with SPAD, anyway). But from my experiments I would guess MCE monitors FSX variables so anything that changes the values has the same effect (Saitek, Elite, clicking the knobs on the Virtual Cockpit). I've since discovered a comment to that effect in mce.ini. I will have a bit more of a play today and see where I get.

Share this post


Link to post
Share on other sites

Actually the Elite driver uses FSUIPC, like Saitek (or Saitek with SPAD, anyway). But from my experiments I would guess MCE monitors FSX variables so anything that changes the values has the same effect (Saitek, Elite, clicking the knobs on the Virtual Cockpit). I've since discovered a comment to that effect in mce.ini. I will have a bit more of a play today and see where I get.

Ah. I actually use the Saitek radio panel with the Saitek driver, not SPAD/FSUIPC, which I acknowledge does have some advantages. I've never tried MCE  with a radio panel driven via FSUIPC (maybe others have ?) But I believe your analysis of what MCE is doing is correct. 

Share this post


Link to post
Share on other sites

 

 


I still get the FO talking ('radio switched to approach', etc.)

 

Assuming you want to fly light aircraft and don't want the interaction with co-pilot, again head to "mce.ini" and change

 

"ForceCopilot=1" to "ForceCopilot=0"

 

next time you start MCE, the "Crew coordination" and "checklist" features will not be available for selection when a non-multicrew aircraft is detected.

Share this post


Link to post
Share on other sites

Assuming you want to fly light aircraft and don't want the interaction with co-pilot, again head to "mce.ini" and change

 

"ForceCopilot=1" to "ForceCopilot=0"

 

next time you start MCE, the "Crew coordination" and "checklist" features will not be available for selection when a non-multicrew aircraft is detected.

 

Okay, ta.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this