Sign in to follow this  
Nespira

Mouse Look Bug. Any help appreciated?

Recommended Posts

Very recently, when i try to pan around my VC using spacebar and my mouse, I am limited to panning up or down only with no ability to move to the right or left.(The indicator cross moves all the way to the side of the screen but the view doesn't rotate). Toggling mouse yoke on or off doesn't seem to be the cause. Does anyone have any idea why this might be happening and how to fix it? I have FSUIPC but i don't use it to pan with mouse look.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

In FSX CONTROL AXES assignments under Mouse Look are these lines all there?

View - left/right axis (pan) Left/Right
View - up/down axis (pan) Up/Down

Share this post


Link to post
Share on other sites

Update. It seems my joystick has gone out of wack as well(Seems to be really sensitive, aircraft banking left and right a lot). Anyone know what might be happening?

Share this post


Link to post
Share on other sites

You can edit the sensitivity by going to Settings > Controls and on the first drop down menu you see, select your joystick. Move all axis (Alierons, Elevators & Rudders) to the desired location for equal sensitivity.

Share this post


Link to post
Share on other sites

Calibrating my joystick and adjusting the sensitivity sliders aren't doing anything. If i sit in the vc i'll observe my yoke randomly banking right or left for atleast 2 seconds without any input. Any ideas?

Share this post


Link to post
Share on other sites

Unplug your joystick and start your Sim without it.  See if you still get yoke movements without imputs.

Share this post


Link to post
Share on other sites

After further investigation, the extreme banking seems to also be applying to mouse yoke in addition to my joystick. Any banking to the left of right seems to always act towards its extreme.(ie. the yoke turns 90 degrees), vertical control however seems to be okay. The problems seem to only relate to left and right movements. All these tests have been performed on the default cessna with no autopilot engaged, just hand flying.

Share this post


Link to post
Share on other sites

Have you tried switching the joystick to a different USB port?

Share this post


Link to post
Share on other sites

Do you by any chance have stick_sensitivity=0 (or something similar) in your cfg?

Share this post


Link to post
Share on other sites

Putting the joystick into a different port didn't work and there were no changes to my cfg. Could this perhaps be caused my missing extensions in the registry? I recently scanned my registry with CCleaner, and selected fix issues. I've done this before, with no problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this