Sign in to follow this  
vortex681

Help! Scenery objects missing after trying DX10

Recommended Posts

DX9 has been working perfectly on my system. I decided to give the DX10 preview a try and didn't really see any performance benefits over DX9. However, when I switched back to DX9 a number of default scenery objects have disappeared. At my home airfield (FSX default, not an add-on), some of the buildings are there but the hangars and the air traffic control tower are missing. The only change to FSX was to go to the DX10 preview and then back to DX9. Add-on airfields seem to be OK. Any suggestions what I can do to get them back?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

 

 


However, when I switched back to DX9 a number of default scenery objects have disappeared. At my home airfield (FSX default, not an add-on), some of the buildings are there but the hangars and the air traffic control tower are missing.

 

Perhaps when you went into DX10 Preview and/or back to DX9, you somehow turned off or changed Scenery complexity, Autogen, and/or Special effects. It is impossible that your default scenery objects have disappeared when you switched back from DX10 to DX9 and vice-versa.  100% totally impossible.   FSX does nothing to your default scenery when you go to DX10 Preview and then back to DX9.  I have to emphasize this as many members have gotten confused with DX10 and DX9.  Microsoft only programmed Acceleration and SP2 so that DX10 elements in your DX10 compatible video card could be used.  There's no such thing as DX10 scenery and DX9 scenery but there is such a thing as DX10 compatible scenery.  When you turn on DX10 Preview, you will be seeing exactly the same thing you saw in DX9 except you will now see some shadows in the VC and better water. If the scenery is not compatible w/DX10 then you need to run a program like AddonConverterX which converts the scenery on the fly (not permanently though). 

 

Me hopes this helps.

 

Best regards,

Share this post


Link to post

I've checked all of my settings and nothing has changed from what I'd previously set. Although you say that it's impossible, it obviously isn't. Scenery objects were all there before DX10, missing when switching back to DX9. No FSX settings are different. I've added nothing and made no config changes. The missing objects are basic FSX buildings, not special bits and pieces that would change with slider settings. I'm stumped!

Share this post


Link to post

Fire hawk is correct, all selecting dx10 preview does is change one setting in fsx.cfg. The only things that can make scenery disappear are a change ( deletion) in the scenery, a change of the scenery ordering in the scenery library or a change in the scenery complexity slider.

Share this post


Link to post

And yet the only thing I did was to try the DX10 preview. I used the same airfield so that I could compare frame rates and assess apparent smoothness. The buildings were there when I started in DX9 but gone when I returned after trying DX10. I understand that DX10 should not have changed any scenery but I can't see any other explanation. Same aircraft, same season and time of day. I only tried DX10 for about 30 minutes and I'm absolutely sure that no other settings were changed.

Share this post


Link to post

Just restarted FSX (for the fourth time) to try to figure out what could be causing the problem and all of the buildings are back! Didn't change anything in the mean time so no idea what caused it. I think it will remain a mystery.

Share this post


Link to post

I'm glad it wasn't DX9 or DX10!!  LOL!  Glad you got it fixed.

 

Best regards,

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this