Sign in to follow this  
cretanpilot

Complete loss of IAS speed.

Recommended Posts

Hello! I Have an issue with Phenom. I have read all the manuals, emergency checklists ets, but i cannot find any solution yet.
So im flying now at 37000ft i have OAT -53oC and my IAS is dead in Both Displays and the Backup also, so i guess that i have ice in my pitot tubes. Since Phenom does not have any pilot heat switches, i opened all the rest anti-ice protections for the engines and surfaces but they have no effect on that. So the question is... what else can i do? Strange but i still have Ground (455kts) and Mach speed (.733kts)...
Some people may suggest to fly in lower altitudes but in the current situation that im flying, i think it's not possible (i will have fuel problem then...).
Thanks...

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try  shift+h  key combo maybe.  That's the default FSX Pitot controls.

Share this post


Link to post
Share on other sites

Hello again! yes i had ADS/AOA knob set to ON. I tried doog79 solution and after a while IAS speeds came back! But im not sure if it was the "Shift+H" or the anti-ice switches that i turned off and on again...
So the next time i will have that issue i will try only the "Shift+H" just to confirm and i will reply back here.
Thank you all for your replies! :)

Share this post


Link to post
Share on other sites

Hello again! yes i had ADS/AOA knob set to ON. I tried doog79 solution and after a while IAS speeds came back! But im not sure if it was the "Shift+H" or the anti-ice switches that i turned off and on again...

So the next time i will have that issue i will try only the "Shift+H" just to confirm and i will reply back here.

Thank you all for your replies! :)

Its shift+h I have the same issue. If the pitot static tube becomes clogged with Ice you'll loose your airspeed indicator as well as other gauges. Just hit shift+h while taxing out and problem is solved.

Share this post


Link to post
Share on other sites

Haha, realax, anti-ice and pitot functions are not simulated completely in FSX... ;) they're just procedures to follow, but there's no real impact on the aircraft...

 

On the other hand, the Phenom cruises at 200 knots or Mach 0.61 (about 280-350 GS, depending on the winds) so Cretanpilot, you were flying so fast!!!!!!!!!!

Share this post


Link to post
Share on other sites

Shift H is default for pitot heat. Love how they made the knob but it doesn't work.... Sigh

Share this post


Link to post
Share on other sites

Pitot heat is automatic in the Phenom 100 so this needs to be addressed by Carenado.  I have the same problem only when taking off in rain and as soon as the outside temp falls below 0C the IAS goes away.  I am using Prepar3d 2.2.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this