Sign in to follow this  
Airshane14

Rudder issues

Recommended Posts

I purchased the Carenado Phenom, a long awaited excitement for me, only to be disappointed with several issues.  I am not able to figure out why I don't get any rudder reaction when I am lining up to land, it is just like the yaw damper or something else is preventing it from working.  This is frustrating especially when coming in on a crosswind landing.  The other disappointment is how impactful it is on FPS, as the other Carenado add ons give me a consistent 20 FPS, which is good for my system.

 

I wish Carenado would listen to us that pay big bucks to get these add ons, and hopefully address these issues.  Any help with the rudder issue would be greatly appreciated.  BTW, I did see the YD is off, and for some reason the CAS shows "YD Fail", which is not indicated in their manuals.  Thanks.

 

Shane

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Is the YD on or off? If it's on, in default based autopilot aircraft such as this phenom, it will kill the rudder inputs. It needs to be off to have any chance.

 

Oh I can't read... So it's off? Hmmm I'll have to go check mine. I think the switch isn't actually working because my rudder still violently goes from right to left in external view even with YD off.

Share this post


Link to post
Share on other sites

I noticed that too. Once you turn the YD on it's on forever.

 

I'm surprised at how poorly this airplane is coded. Service Pack should be huge if they bother to fix this plane.

Share this post


Link to post
Share on other sites

Hi guys,

I too have just brought the Carenado Phenom 100 and straight away I had the issue with the rudder not working.............(it is very heavy on frame rates too).

 

Here is what happens to my Aircraft, the rudder works perfectly untill I engage the auto pilot...then when I disengage it I can climb, descend and bank no problems but the rudder refuses to work as if the auto pilot or Yaw Damper is still on.........

 

I found a short term solution. It is all to do with the Yaw Damper not disconnecting for some reason? (Bug). The only way to get the rudder to work normally again is to go to your key board and select CTRL+"D" to manually disconnect it and it will then work normally. (I have mapped a button to my joystick for the time being).

 

Best of luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this