Jump to content

Archived

This topic is now archived and is closed to further replies.

vincentliew96

737 ngx faulty mcp

Recommended Posts

recently i`ve installed a new 737 ngx for my fsx

the mcp lights wasnt on..

i`ve tried reinstalled it twice..

it still wasnt working...

 

need some help from the support team....!

 

Share this post


Link to post
Share on other sites

Just to be sure...load the default profile via the CDU/FMC and wait a minute or two for all systems to come alive...does the MCP light up?

Share this post


Link to post
Share on other sites

If you need proper support, you need to lodge a ticket via the website.

Also, you better sign your name before everyone else tells you to do it.

Did you enter in the registration key to ensure its properly registered?


Brent Lewis

Share this post


Link to post
Share on other sites

im sorry here`s the detail

 

yup sir i im using the house livery 737-800 WL

even i waited for the 20 seconds but it still didnt light up....

infact im following the steps in the first tutorial...

 

 

 


 


 


 

Share this post


Link to post
Share on other sites

is there anything i did wrong?

Not insert the registration key

 

But,you could have a fault with the fonts.. best way is support ticket..


Brent Lewis

Share this post


Link to post
Share on other sites

Go to support.precisionmanuals.com and submit a ticket. Don't forget, the support portal doesn't use the same account as AVSIM or the Store. If you don't have an account at the support portal yet, you'll need to create one.


Name available upon request


AVSIMSig.jpg


 

Share this post


Link to post
Share on other sites

×
×
  • Create New...