Sign in to follow this  
eagle39

Night Textures

Recommended Posts

I could use some help with night lighting of buildings.

 

I used “Creating Night Textures for Scenery” by Al Heline. After making changes the building was saved in .jpg form. I then converted the file to DSS using the DXTbmp program.

 

Used Model Coverter X to convert the buildings for FSX.

 

Created model file and bgls and placed buildings using Airport Design Editor.

 

The daytime building shows but when going to nighttime the building will appear but no night lighting.

 

Any help you can provide would be much appreciated. I have been working on this for months and cannot come up with a solution.

 

Thanks,

Wayne

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

While you have the models in MCX are you assigning night textures to the materials?

 

regards,

Joe

Share this post


Link to post
Share on other sites

Since you're using MCX, click the night render mode button to see if the night textures appear. Also make sure to put the night texture files into the texture folder next to the scenery folder.

Share this post


Link to post
Share on other sites

Thanks for the comments, but I still cannot get it to work. The terminal building is the front view as that is the only side I can apply the night lights to.

 

The night texture has LM and is in the texture file for the airport I am working on.

 

When using MCX and clicking on the night texture item the LM file does not shown and I have to type the file into the box provided.

 

Wayne

Share this post


Link to post
Share on other sites

you probably need to defuse a mask for the image to show up

if you're only seeing one sided texture; you may need to apply the texture as two sided

Share this post


Link to post
Share on other sites

 

 


When using MCX and clicking on the night texture item the LM file does not shown and I have to type the file into the box provided.

 

That means you have not assigned a night texture to the material.

 

After typing in the _LM file name (there is an easier way) you then have to export the model again.

 

Load your model into MCX.

 

Open the Material Editor.

 

On the Properties tab click on the texture(s) you want to add night textures to.

 

In the top, right corner is a dropdown box (you are using the latest development release and not v 1.3, correct?) which should have "Add Night Texture" in it. To the right of that box is an "Apply" button. Click it.

 

Do this for all textures that you want to have night textures.

 

Export your model.

 

This process will not make the actual textures, you have to do that. All you are doing in MCX is setting a flag in the model that tells FS to use night textures.

 

regards,

Joe

Share this post


Link to post
Share on other sites

Joe, it sound like he started from scratch

the process your describing is for existing model with texture your just replacing

he still has to configure how the texture is manipulated, stretched and presented in his model

Share this post


Link to post
Share on other sites

Thanks, Joe, that sure helped and I am now getting the night textures to show.

 

Also thanks to all who responded.

 

Wayne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this