Sign in to follow this  
WebMaximus

Microphone volume level drops when starting FS2Crew

Recommended Posts

Hello Bryan, long time no see.

 

I have a very weird issue and just wanted to ask if you have any clue what might be causing this.

 

What happens is that when starting FS2Crew at the very same moment I click the clickspot the volume of my microphone drops down to 18%, I normally have it set at 75%.

 

I have tried several different settings like unchecking the option in Windows 7 to allow applications to take exclusive control of the device, making sure 'Do nothing' is checked on the Communication Tab under Sound settings, unchecking all effects for the microphone on the Effects tab etc etc but all to no avail.

 

After doing some Google searching I've learned that I'm far from alone having issues in Windows 7 with the microphone volume slider living it's own life and not only when running FSX so this problem is not isolated to FS2Crew...I just happened to see that starting FS2Crew is one thing that will make the mic volume adjust by itself and in my case drop to 18%.

 

Yesterday I came across one thread where it was suggested to use some freeware tool to constantly reset the mic volume to a preset level you choose but I rather not use such a tool that needs to be running in the background all the time.

 

This is very annoying so please say you know about this issue and have a pure cure for it in your back pocket ;)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Richard,

 

Out of thousands and thousands of users, that's a new one I'm afraid.

 

My advice would be to ensure any programs running in the background are disabled.

 

I'm guessing one of them is somehow interfering with the mic somehow.

 

That one's a needle in a haystack.

 

Since I know you've been using FS2Crew voice for a very long time, I assume this just happened out of the blue?

Share this post


Link to post
Share on other sites

Hi there Bryan and thanks for your prompt reply!

 

Speaking about programs running in the background when I have FSX started I think you are on the right track because I don't see my mic volume behave like this normally when I don't have FSX including all extra programs running.

 

Problem is all the programs I have running in the background when using FSX are programs I need to have running and they are all related to FSX and to further narrow down this issue I think the programs messing with the mic level are the addon programs that are voice-enabled in some way such as FS2Crew and vPilot (the new Vatsim client).

 

On the other hand I don't think any of these programs are actually to blame for this but rather how Windows handles all this because like I said in my post above there are LOTS of info to be found on this if you do a Google search for something like 'windows microphone volume level'.

 

Posted about this over in the general hardware forum here on Avsim as well so maybe if I'm lucky I will get some feedback there. Otherwise I guess I'll just have to learn to live with having to check the mic volume every now and then making sure it's set the way I want it.

 

Your assumption is correct but not fully so because I've seen this problem in the past as well but not as often as now and when I had this issue in the past I didn't always even notice I had this issue unless ATC on Vatsim or IVAO for instance told me my mic volume was very low when I was speaking. Reason I've started to notice this problem now is that I'm doing lots of FSX recording and then it's very annoying when you find after you already finished recording that your own voice is barely audible in parts of the clip. 

Share this post


Link to post
Share on other sites

 

 


On the other hand I don't think any of these programs are actually to blame for this but rather how Windows handles all this because like I said in my post above there are LOTS of info to be found on this if you do a Google search for something like 'windows microphone volume level'.

 

If it was Windows, though, I'd be experiencing it probably and I'd be hearing about this 20 times a day.

 

Try isolating your background programs; it must be one of them. 

 

Cheers,

Share this post


Link to post
Share on other sites

Well...problem is the only programs I'm running in the background that are audio-capable are programs I need for FSX FS2Crew being one of them where I'm also able to reproduce the issue every time by simply starting FS2Crew which results in my mic volume dropping to 18%

 

I think at this time I won't be able to stop FS2Crew and any other program from messing with my mic volume but instead I need to find a way if possible to lock the volume slider from moving. I've posted about my problem in other fourms as well not related to FSX asking if it maybe possible to accomplish that using some reg hack or even a Windows policy.

Share this post


Link to post
Share on other sites

Found a solution to my problem. Not the prettiest one but at least it works.

 

I found a freeware command line utility called NirCmd which is capable of setting the mic volume so I simply scheduled 12 tasks in Task Scheduler to run this command setting the mic volume to the level where I want it every 5 seconds :)

Share this post


Link to post
Share on other sites

 

 


Found a solution to my problem. Not the prettiest one but at least it works.
 
I found a freeware command line utility called NirCmd which is capable of setting the mic volume so I simply scheduled 12 tasks in Task Scheduler to run this command setting the mic volume to the level where I want it every 5 seconds :)

 

Thanks for sharing.

 

Should anyone ever experience your issue, that could help them!

 

Cheers,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this