Sign in to follow this  
ejoiner

FA/FSX(SP@) and Win81 = loss of joystick?

Recommended Posts

Hi guys.   I fly FSX SP2, under win8.1 normally without any problems.  Recently I purchased Fiber Accelerator and now have found a problem.  When I go from full screen mode to windowed mode, in order to tweak FA,  often when I return to FSX,  the sim has switched to mouse mode control and no longer sees my saitek X55 Rhino HOTAS set up.    Quite annoying to be half way through an approach to landing and lose all control input!!!

 

I wrote to FSPS tech support, who wrote me back indicating this has nothing to do with Fiber Accelerator, but is a bug in FSX/Win81 ?  Havent heard of that, but I also have never had to switch between applications dynamically like with this tool.   Anybody else heard of this or experienced the same?  is there a fix?

 

I hate to say it, but if there is no fix, i will drop using Fiber Accelerator because obviously my set up is incompatible with its use.

 

Eric

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Losing the joy stick is a known issue with Windows 8.X.

 

Try disabling the USB Power Saving option by going to Power Options, select your current power plan and select "Advanced Options".

Share this post


Link to post
Share on other sites

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "WIN8 OS Forum". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

I'm not convinced the joystick issue here is the same one as the known win8 one.  I am 8.1 with many joysticks attached rudder, throttles sticks etc and have not had any issue with them until i ran FA, as soon as it runs all joysticks are removed from FSX and only the mouse remains, joysticks are still active within the windows envionment.  Also support response from fsps was nothing to do with us, dissapointing attitude.

Share this post


Link to post
Share on other sites

Maxy, I am actually with you on this one.  I did the power management trick on the USB ports and still had the same problem.  I use a Saitek X55 HOTAS system which is actually two USB devices separately managed by the system.   One throttle and one stick/rudder (twist grip) combo.     I wonder if Saitek should be brought into this conversation?

Share this post


Link to post
Share on other sites

@Maxybo.

 

You said... "Also support response from fsps was nothing to do with us, dissapointing attitude."

 

Is this dissapointing?

Would it be better if we had respond "oh yes it's our fault" (despite we have nothing to do with that) and never be able to find for you a solution ? I doubt...

 

It is like cursing the CAT scan machine for discovering a tummor on your body on a routine check-up...

 

"Win8 - joystick - fsx". Like saying "home computing with windows 95"

Share this post


Link to post
Share on other sites

I had same problem with G940 and it appears only when FA was running but I found solution. Try to turn off joystick in FSX and then remap all axes in FSUIPC. Works fine for me.

Another problem which I have is with PRO-ATC X which is also deactivated by FA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this