Sign in to follow this  
stampee

cpu and gpu not maxed out, yet lower frame rates and stutter

Recommended Posts

Hi all: I have an amd fx8350 8 core and 7950 video card, 3 gig, and 16 gig system memory.

flying in laguradia with albeit to high visual settings I get around 12-25 fps. ( I know not really flyable, but I am using this as a test)

In the past task manager always showed my system at 100% cpu use on core 0 and the other 7 cores hovering around 25-40% depending on who knows what. So I assumed this is the best I would ever get with frame rates and I realized I could not expect any more frame rates.

yesterday I installed the microsoft bulldozer hotfix for threads and scheduling. Now I see my cpu 0 core around 75-85% sometimes for a second or two at 100% but it averages around the 75% mark. the other cores about the same at 25-40% useage. I then installed msi afterburner.

Using the OSD I see gpu around 75-80% and core 0 around 75-90% also. task manager still shows the same around 75% also on core 0

I still see about the same frame rates, but the lower usage percentages.

Is their another bottleneck in my system I do not know about? or am I just getting more accurate numbers now then I previously had been getting. I would just assume that the cpu or the gpu should always be at, or close to 100% if I am using all resources properly.

I have affinty in task manager set to use all cores. I could not figure out what should be used for an AMD processor in the cfg file, and gave up. everything I read online is for intel processors and hyper threading and I get lost.

perpar3d version 2.2 right now also.  

THANKS to all.

-Stampee

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

You have AMD cpu 4 Ghz with 8 cores.The FSX  or P3d use only 2 - 3 of them,the others for sceneries,windows OP,background programs etc.please control your settings for a suitable and optimized simulation

Share this post


Link to post

Hi all: I have an amd fx8350 8 core and 7950 video card, 3 gig, and 16 gig system memory.

flying in laguradia with albeit to high visual settings I get around 12-25 fps. ( I know not really flyable, but I am using this as a test)

In the past task manager always showed my system at 100% cpu use on core 0 and the other 7 cores hovering around 25-40% depending on who knows what. So I assumed this is the best I would ever get with frame rates and I realized I could not expect any more frame rates.

yesterday I installed the microsoft bulldozer hotfix for threads and scheduling. Now I see my cpu 0 core around 75-85% sometimes for a second or two at 100% but it averages around the 75% mark. the other cores about the same at 25-40% useage. I then installed msi afterburner.

Using the OSD I see gpu around 75-80% and core 0 around 75-90% also. task manager still shows the same around 75% also on core 0

I still see about the same frame rates, but the lower usage percentages.

Is their another bottleneck in my system I do not know about? or am I just getting more accurate numbers now then I previously had been getting. I would just assume that the cpu or the gpu should always be at, or close to 100% if I am using all resources properly.

I have affinty in task manager set to use all cores. I could not figure out what should be used for an AMD processor in the cfg file, and gave up. everything I read online is for intel processors and hyper threading and I get lost.

perpar3d version 2.2 right now also.  

THANKS to all.

-Stampee

 

The fact that neither CPU or GPU load upto 100% seems true generally, and not a AMD FX issue. I have a 4700MQ with 755M SLI and I have similar loadings.

 

I also have FX8350, but I am not using it right for P3D/FSX. You best bet to get more performance out of FX8350 would be be to disable 4 cores and over-clock the rest. At least that's what helped me in FSX.

 

The affinity mask issue is not trivial, I think. Piledriver seems to be built with pairs of cores sharing "bits". I think the most optimal setting would be to leave the first core pair out (for the OS etc), use the first core on the 2nd pair for main but leave its second core out. And use the rest of the four cores (two pairs). Something like 11 11 01 00. Leaving the 2nd core on 2nd pair out would help the 1st core. At least that's what I think, but I may be totally wrong.

 

Anyway, if I remember correctly, using more that 4 cores for FSX did not improve anything for me.

Share this post


Link to post

 Why are you still running v2.2? P3Dv2.3 makes more efficient use of your cpu. You will not see 100% across all cores, but they will be used. If you do stick with 2.2, and want to put an affinity mask setting in the cfg file; use 255. P3D runs smoother with all cores active. You will see much faster/smoother texture loading.

 

  Jazz

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this