Sign in to follow this  
thepilot

Logitech Extreme 3D Pro unsteady z axis

Recommended Posts

Hello all,

 

I'm still using a Logitech Extreme 3D Pro joystick for flightsim. It has given me good service over the years but I now have a problem with it: The z axis which controls the vertical stabilizer and the front wheel on the ground has become loose. Whenever I touch the joystick, I indeliberately cause the z axis to move, which leads to noticeable oscillations of the vertical stabilizer in the air. I've tried calibrating the joystick but to no avail. This is apparently a common issue with the Extreme 3D Pro. I'm not really looking for a mechanical solution, but thought about adding a null zone, so that only stronger inputs are actually recognized. Does someone maybe have an idea how to go about this? It would be greatly appreciated!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Logitech uses cheap $.005 potentiometers in these joysticks and I've experienced the problem you describe hundreds of times. I've taken my stick apart and flushed the pots out with soap & water followed by compressed air to dry them back out, that does make the joystick nice and smooth again for a while but the problem always returns after a month or so.

 

What I usually do before I get ready to fly is work the stick back & forth on all axes a few dozen times (hold it upside down by the stick and shake the h*ll out of it in all 3 directions), then set it down on the desk, unplug it, and then plug it back in which should center everything up. When you start the sim go into slew mode and check that the stick is centered, if the plane spins easier in one direction than the other unplug/plug the stick again until it centers properly.

 

After that, if you have the registered version of FSUIPC you can use the joystick calibration feature to smooth out the control inputs and remove spikes which also helps.

 

Jim

Share this post


Link to post
Share on other sites

I used to have one of these and my Z Axis turned to trash after about 2yrs also.  Same exact symptoms. Just vaguely touching the stick would send the Z Axis into twitchy behavior. Setting deadzones helped but you usually had to set them so big it killed the point of having a Z Axis in the first place. There is no fix, no cure except not to buy Logitech controllers again. They make great mice and keyboards, not controllers.  I just fly stick aircraft with the yoke. I never bothered buying a new flight stick. 

Share this post


Link to post
Share on other sites

Thanks guys. My current joystick is actually the second Extreme 3D Pro I've bought over the years. The first one I discarded because of that issue. I like it a lot otherwise, and I see they are still selling it at a rather hefty price. I must say I'm a bit disappointed that Logitech hasn't come up with a newly-developed joystick since a long time. Anyway, I didn't quite realize that I can add and adjust the null zone in FSX itself. I had to turn up the slider just a little and now I consider that problem fixed. Did a test flight too last night and it worked liked a dream. Still, a high-end joystick or even a better yoke is now on top of my wish list.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this