Sign in to follow this  
Gabshall

Disappearing landing lights

Recommended Posts

Dear all

 

This is my first post on Avsim after years of lurking, so I'd like to start by offering my sincere thanks to SteveFx for bringing FSX back to life (at least for me). The reason I've emerged from anonymity is because I've encountered a problem for which I can't find a solution. With the fixer libraries installed, some of my aircraft (stock, e.g., Beechcraft Baron and add-on, e.g., Carenado Mentor) exhibit disappearing landing lights approximately 1000 ft after take-off. The landing lights are present before take-off (I'm referring to the effect on the aircraft not illumination of the ground), disappear during flight and re-appear when approaching the ground. Uninstalling the fixer libraries removes the issue (but of course introduces all the old problems). I've tried installing with and without the DX10 light package and DX10 compatible effects, but with no success. Having V2 lighting rules on or off has no effect (but I believe this only affects scenery).

Does anyone have a possible solution or suggestions?

Thanks in advance.

Best wishes.

 

Garry.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Are you referring to the shine on the aircraft or the "light" that you see from the spot view in front?

Share this post


Link to post
Share on other sites

Forgot to indicate I'm using v2.4 of the Fixer.

 

Garry.


Dear Steve

 

Thanks for such a rapid response! I'm referring to the light seen from spot view in front of the aircraft.

Best wishes.

 

Garry.

Share this post


Link to post
Share on other sites

So you take off in the stock baron fly up to 1000ft AGL keep the undercarriage down and in spot view look from the front - correct?

Share this post


Link to post
Share on other sites

Correct. From front spot view the landing lights are on until approx. 1000ft then just disappear. Undercarriage extended or retracted.

Share this post


Link to post
Share on other sites

Are these the standard lights then? on the default baron the landing lights are on the undercarriage and so go off when its raised.

 

I am not trying to catch you out - just want to understand we are looking at the same thing!

Share this post


Link to post
Share on other sites

Please accept my apologies Steve, I was referring to the Carenado Mentor which has landing lights in the wings. You are of course right that the lights on the Baron retract with the undercarriage (deeply embarrassing that I hadn't noticed before!!). Now I know what emoticons are for :blush:. So default lights are ok, it's presumably just the Carenado fx files.  I did try a re-install of the Mentor but that didn't solve it. Will try re-installing again. Probably best to leave it here before I make any more mistakes. Thanks for your time.

On a final note - thank you again for publishing your software and making FSX so enjoyable.

Best wishes.

Share this post


Link to post
Share on other sites

No need to apologise! If it happens with DX10SF installed and doesn't happen without it then it must be DX10SF related in some way.

 

Can you look in the aircraft cfg file and find the lights section and see if the landing light effect is referenced by name there.

Share this post


Link to post
Share on other sites

Hi Steve

 

A third re-install of the aircraft stopped the Mentor's lights from disappearing. So presumably the problem relates to modification of a Carenado fx file by the fixer.

The Mentor cfg file references the landing lights to fx_strobecarenmen. I added this to the exclusion list, but the lights still disappeared. So working backwards, I added all the lights to the exclusion list and started subtracting one at a time to determine which one was causing the problem. To my surprise, excluding only fx_navgrecarenmen from conversion stopped the landing lights from disappearing. Of course now the aircraft has no starboard nav light, which is more distracting from the vc. So the compromise is to lose the landing lights and keep the nav light visible from the cockpit.

I'm not asking you to fix this, but just reporting back because you were kind enough to point me in the right direction.

Perhaps I could substitute a different navgre file reference in the cfg to solve the problem. Will have a go (or maybe I should leave it alone!)..

Thanks again for your patience and help, it is really appreciated.

Best wishes.

Share this post


Link to post
Share on other sites

Firstly that's quite impressive investigation on your part!

 

If you hunt on my blog for my investigations on lights - in DX10 lights are totally messed up but after a multiple lights with a change of texture they seem to start working - it must be some initialisation bug I guess.

 

If you change the green nav light for the default fx lights fx_navgre.fx with dx10sf installed and the dx10 light package it should be ok.

 

Alternatively if you are really brave uninstall the light package have a look at the fx_navgre.fx lights - then look at the changes that I make when you install the light package - I insert some extra entries into the file which force a change of texture.

 

If you make similar changes to the original light it may fix it.

Share this post


Link to post
Share on other sites

Directing the Mentor cfg to the default fx_navgre fixed the landing light problem and returned the starboard light, but how could I resist the challenge? The Mentor fx_navgre file is simpler than the default and only contains four ParticleAttributes. I modified the ParticleAttributes.2  entry to reflect your alternative texture and it worked! Landing lights no longer disappear at 1000ft agl and the aircraft has starboard nav visible form the vc. So now I have two fixes.

 

Finding the source of the original problem was only possible because the exclusion function on the fixer was such a useful diagnostic tool. The fixer software is an impressive application.

 

Many, many thanks.

Share this post


Link to post
Share on other sites

No problem at all - if you need any other information feel free to ask.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this