Sign in to follow this  
Rusty107

Aerosoft A318/A319 + Saitek Multi-Panel

Recommended Posts

Hi

 

I have posted this in the Aerosoft Forums however, it was mentioned it may be better suited for here :smile2:

 

I have both Linda 1.13 and the Airbus X module 3.01 installed, I am using P3D 2.4 with the latest (licensed) copy of FSUIPC and SPAD drivers. I cannot seem to get my Saitek Multi-Panel to operate any of the Airbust FCU controls (with the exception of the flap lever)? I have tried using both Linda and FSUIPC without success. Has anyone managed to get these work together, of if there was a detailed 'how-to guide somewhere?

 

Any help would be greatly appreciated, many thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Rusty

 

Good to see you on this forum. You will find there is more expert help on LINDA here.

 

If you go to the LINDA settings page you will see the Manual listed. This is the best and most comprehensive guide to the program. You are using the most up to date software and module (note Airbus module 3.01 is not compatible with LINDA 2.0.8).  A new version of LINDA, 2.1, with a compatible A318/319 module is in test).

 

However, that does not solve you problem. LINDA is ideal for managing device buttons and slow repetition functions. It does not cover axis like throttle and lever with a proportional output. You need to program these with FSUIPC. Also high rate repeating buttons (such as thrust reverse) are also best done in FSUIPC.  Getting back to LINDA, first start LINDA and then P3D with the A318/319. Then check that 'Aerosoft Airbus' appears in the top dropdown and the FSX sync turns orange. This means LINDA can use the Airbus module functions. You can tick a box in settings to start LINDA automatically.

 

Does your Saitek multi-panel appear in the Joystick/HID list and how many buttons/axes/hat are listed? See Settings/Joystick page for this. If LINDA is seeing your panel, then click on the top Joystick button of the LINDA header. Pressing each button or switch should highlight a line against a number. Simply click on the first box on this line to assign a function from the list (into those from the Airbus module).

 

If this does not help, come back to me.

Share this post


Link to post
Share on other sites

Hi ScotFlieger

 

Many thanks for the reply its much appreciated :smile:

 

Just t be sure this is the unit I refer to:

 

http://www.saitek.com/uk/prod/multi.html

 

I have selected the Aerosoft Airbus from the drop down. The Multi Panel looks to be available, as when I press a button it registers on the program? My first attempt was to simply apply the AP on the Saitek Multi Panel with the value AP1 Toggle within the module without success, I have also tried the same simple assignments HDG, ALT, VS, APP. I have SPAD installed if that makes adifference?

 

Thanks again for any guidance!

 

Cheers

 

Rusty

 

 

Share this post


Link to post
Share on other sites

Hello Rusty. I have the identical problem with my saitek multi panel. You are not alone. I have tried everything I know (took about a minute !) without success. I did manage to get the panel working with the pmdg 777 and ngx using spad, linda and fsuipc.That was down to key assignments in the fmc. The Aerosoft aircraft don't have that facility so I'm a bit stuck too.

 

Rob

Share this post


Link to post
Share on other sites

The bad news is that there are issues with using the Saitek Multi- and Radio panels with LINDA and especially with the Aerosoft Airbus. The good news is that I have brought these panels for development and testing. I have yet to start detailed investigation but watch this space.

 

The Saitek Switch Panel was already integrated and the landing gear lights do work. The switches can be programmed in LINDA but need a special set up. You have to program the ON PRESS function the activate the switch ON function and the ON RELEASE function for to cancel (ie turn if OFF). This is because of the way Saitek has wired up these switches.

Share this post


Link to post
Share on other sites

The Saitek Switch Panel was already integrated and the landing gear lights do work. The switches can be programmed in LINDA but need a special set up. You have to program the ON PRESS function the activate the switch ON function and the ON RELEASE function for to cancel (ie turn if OFF). This is because of the way Saitek has wired up these switches.

 

 

Good evening man, i tried to do like this but it only turns ON but it wont turns off! I have 2.8.5 Linda version. Could you help me? Thanks

Share this post


Link to post
Share on other sites

Good evening man, i tried to do like this but it only turns ON but it wont turns off! I have 2.8.5 Linda version. Could you help me? Thanks

 

 

There is an issue with LINDA 2.8.5 with setting up the configuration of the OnRelease functions which is used for the Saitek Switch Panel. After loading your aircraft, click on Reload LUA Engine to fix the problem.

Share this post


Link to post
Share on other sites

There is an issue with LINDA 2.8.5 with setting up the configuration of the OnRelease functions which is used for the Saitek Switch Panel. After loading your aircraft, click on Reload LUA Engine to fix the problem.

 

Done..unfortunately doesn't fix it!

Share this post


Link to post
Share on other sites

I suggest you install 2.8.4 for the meantime. Make sure that you have the ON action assigned to the OnRepeat and the OFF to the OnRelease.

Share this post


Link to post
Share on other sites

2.8.6 still doesn't work! :sad:

 

 

Please give me a clue. What does not work? I am afraid I don't do mind reading.

Share this post


Link to post
Share on other sites

Good evening man, i tried to do like this but it only turns ON but it wont turns off! I have 2.8.5 Linda version. Could you help me? Thanks

 

 

This...btw a lot of issues with Saitek Multi and Radio Panel

Share this post


Link to post
Share on other sites

This...btw a lot of issues with Saitek Multi and Radio Panel

That helps a lot. Not. I need to see your aircraft config-hid.lua and the fsuipc4.log files. Please email to linda@awginfosys.net. Please help me to help you.

Share this post


Link to post
Share on other sites

Hi Forum,

I have a big issue with Aerosoft Airbus and SAITEK Panel too.

 

FSX Acceleration

LNDA 2.8.6,

Airbus A 318/19/20/21 Module in Version 4.3

Aerosoft Airbus A31819/20/21 of course.

 

After installing LINDA and Airbus module, Linda Settings Screen showed "everything is ok". Thus I started to configure the Buttons (Saitek Switch Panel)

 

But nothing happend in FSX. If I press a button on the Joystick, the respective field in LINDA is highlighted, but no influence in the Cockpit.

 

Hopefully, someone can help me

 

Erwin

Share this post


Link to post
Share on other sites

Hi Forum,

I have a big issue with Aerosoft Airbus and SAITEK Panel too.

 

FSX Acceleration

LNDA 2.8.6,

Airbus A 318/19/20/21 Module in Version 4.3

Aerosoft Airbus A31819/20/21 of course.

 

After installing LINDA and Airbus module, Linda Settings Screen showed "everything is ok". Thus I started to configure the Buttons (Saitek Switch Panel)

 

But nothing happend in FSX. If I press a button on the Joystick, the respective field in LINDA is highlighted, but no influence in the Cockpit.

 

Hopefully, someone can help me

 

Erwin

 

 

Hi Erwin

 

Welcome to the LINDA community forum. It is possible to program the Saitek Switch Panel to operate with the Aerosoft Airbus. The problem with the Switch Panel is that you need to allocate the ON function to the OnPress and the OFF function to the OnRelease (the OnRepeat should be left Empty). For example, Button 8 OnPress should read Lights_PANEL_on, OnRepeat reads Empty and OnRelease should read Lights_PANEL_off (using Aerosoft Airbus module functions). My setup for the Switch Panel in my \modules\linda-cfg\aircrafts\aerosoft airbus\config.lua are:

 

-- ## Switch Panel ## (06A30D670) ## {NoSerNum} ############

 
JSTK["06A30D670"][1]="Battery_BOTH_on"
JSTKrl["06A30D670"][1]="Battery_BOTH_off"
JSTK["06A30D670"][2]="Alternator_on"
JSTKrl["06A30D670"][2]="Alternator_off"
JSTK["06A30D670"][3]="Avionics_MASTER_on"
JSTKrl["06A30D670"][3]="Avionics_MASTER_off"
JSTK["06A30D670"][4]="ALL_FuelPumps_on"
JSTKrl["06A30D670"][4]="ALL_FuelPumps_off"
JSTK["06A30D670"][5]="Lights_CABIN_on"
JSTKrl["06A30D670"][5]="Lights_CABIN_off"
JSTK["06A30D670"][6]="DeIce_PITOT_on"
JSTKrl["06A30D670"][6]="DeIce_PITOT_off"
JSTK["06A30D670"][8]="Lights_PANEL_on"
JSTKrl["06A30D670"][8]="Lights_PANEL_off"
JSTK["06A30D670"][9]="Lights_BEACON_on"
JSTKrl["06A30D670"][9]="Lights_BEACON_off"
JSTK["06A30D670"][10]="Lights_NAV_on"
JSTKrl["06A30D670"][10]="Lights_NAV_off"
JSTK["06A30D670"][11]="Lights_STROBE_on"
JSTKrl["06A30D670"][11]="Lights_STROBE_off"
JSTK["06A30D670"][12]="Lights_TAXI_on"
JSTKrl["06A30D670"][12]="Lights_TAXI_off"
JSTK["06A30D670"][13]="Lights_LANDING_on"
JSTKrl["06A30D670"][13]="Lights_LANDING_off"
JSTK["06A30D670"][14]="Engine_stop"
JSTK["06A30D670"][15]="ALL_ENG_magneto_R"
JSTK["06A30D670"][16]="ALL_ENG_magneto_L"
JSTK["06A30D670"][17]="ALL_ENG_magneto_Both"
JSTK["06A30D670"][18]="Engine_start"
JSTKrp["06A30D670"][18]="Engine_start"
JSTK["06A30D670"][19]="Gears_up"
JSTK["06A30D670"][20]="Gears_down"

 

Unfortunately, the Saitek Multi-Panel rotary knob functions (ALT, HDG, etc) only work with the FSX default aircraft values and not 'advanced' aircraft like Aerosoft Airbus. The AP buttons, flap level and Auto Throttle buttons/switches can be assigned as per above.

Share this post


Link to post
Share on other sites

Hi Scotflieger,

thank you very much for your quick response, but the problem still exists.

 

I checked my config.lua with your entries in your post, and they are more or less the same. But if  I operate the button, nothing happened in the AirbuscCockpit.

 

In LINDA, the FSX sync shows orange.

 

I use the newest SAITEK drivers - is this  maybe the problem? Do I have to change Drivers?

 

Erwin

Share this post


Link to post
Share on other sites

Hi Scotflieger,

thank you very much for your quick response, but the problem still exists.

 

I checked my config.lua with your entries in your post, and they are more or less the same. But if  I operate the button, nothing happened in the AirbuscCockpit.

 

In LINDA, the FSX sync shows orange.

 

I use the newest SAITEK drivers - is this  maybe the problem? Do I have to change Drivers?

 

Erwin

 

 

You should not be using any Saitek software or drivers to operate their panels with LINDA. The Saitek Panels are treated as joysticks when connected to Windows.

 

If you select LINDA Developer Mode (under LINDA Setup) and Verbose reporting, you should see the keys pressed and function called in the LINDA Console.

Share this post


Link to post
Share on other sites

I removed SAITEK Drivers and I copied your Setup for the Switch Panel in my config.lua.

But without any success.

 

I selected "Verbose" in the LINDA advanced Setting, and I got the result, if I press e.g.  BAT button on the Switch Panel:

 

[LINDA] BTN 06A30D670-5=10010000000000100001>>

>00010000000000100001 bit 1

[LINDA] RL: 06A30D670-5=10010000000000100001>>

>00010000000000100001 bit 1 1

 

To be honest, I have no idea, what does it mean.

 

Regards,

Erwin

Share this post


Link to post
Share on other sites

Sorry. I would not expect you to understand the reports. It is Boxing Day so family is a priority.

 

Please select Verbose and tick both LUA and GUI boxes. Then restart your Flt sim and run Airbus. Toggle each switch a couple of times. Then email to LINDA@awginfosys.net the files FSUIPC4.log and the config-hid.lua for Airbus. I will then check and reply when I have time.

Share this post


Link to post
Share on other sites

Dear Support Forum,

my problem has been solved, many thank's to ScotFlieger :smile:

The problem was a wrong config-vri.lua file in my modules\linda-cfg\System Directory.

 

Great events often come from little causes!

 

Thank's again

Erwin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this