Sign in to follow this  
Nick M

Light effects bleed-through: 'ClipMode = Minimum' fix?

Recommended Posts

Hi All,

 

I've been using FSX for several years and have noticed the effect for nav, strobe and beacon light occasionally show through the virtual cockpit walls. The artefact is a bit difficult to reproduce as seems to depend on the exact view direction, zoom level and so on.

 

I recently read this post on the A2A forum which suggested a fix. (The advice below seems to come from Milviz originally.)

 

For best visual results it is *highly recommended* that the user edit their default FSX Cameras.cfg file to add a missing entry. The default Cameras.cfg file is located in the same folder as the active fsx.cfg file.

Open Cameras.cfg with Notepad.exe and add this single line to the second camera definition:

ClipMode = Minimum

This line should be placed just after the Origin = Virtual Cockpit entry, as shown below...

[CameraDefinition.002]
Title = Virtual Cockpit
Guid = {C95EAB58-9E4A-4E2A-A34C-D8D9D948F078}
Description = This is the description of the virtual cockpit view.
Origin = Virtual Cockpit
ClipMode = Minimum // <==== add this line!!! //

 

I duly added the 'ClipMode = Minimum' line to my camera.cfg and it seems to have fixed this old FSX bug.

 

As I haven't seen this edit to the camera.cfg file widely discussed here or anywhere else, I just wondered if other FSX (or P3D) users have tried it.

 

If so, does it work for you? Any unwanted side effects?

 

Cheers,

Nick

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Nick, I know this post is a year old, but just thought I would let you (and anyone else) know, that I tried the fix, and I do see a big improvement. I still do get a bit of bleeding of lights through the walls of the VC, but not nearly as bad as it used to be. And no side effects so far. Thanks for your post!

Share this post


Link to post
Share on other sites

Hi !

I tried this trick, but regularly saw the runway lights through the mountains, especially at night. It took some time before I realized the cause of visual defect. I restored the original config, and the error was gone

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this