Sign in to follow this  
zmak

Device cannot be opened

Recommended Posts

Hi

 

Im getting an error message trying to install  V2.5

I dont have the MCP combo

Any help appreciated

 

 

lindacannotopen_zpsdc858786.png

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Zoran

 

You need to select the MCP Setup page and disabled the MCP by unpicking the box. Then close and reopen LINDA and that error should go away.

 

If it does not can you list the devices and joysticks you have connected.

Share this post


Link to post
Share on other sites

Do you mean "set up mcp combo"   thats unchecked already

 

This version wont recognize any controllers so the Joystick section is empty. I have the vr insight M panel but that is not supported ?

 

I kept my Cong hid.lua as mentioned in the set up instructions. Let me know if you need more pics

 

edit

 

joystick is Microsoft sidewinder FFB

Saitek throttles

Share this post


Link to post
Share on other sites

Hi Zoran

 

Sorry I was up early and not awake. You screen shot (now removed) did show the MCP disabled.  Can you try again after disconnecting the VRInsight M Panel?  If that does not work, rename your config-hid.lua file and try again. 

Share this post


Link to post
Share on other sites

No probs, Mpanel disconnected and config-hid.lua file renamed however it didn't help.

 

The new  config-hid.lua file  isn't showing My controllers

Share this post


Link to post
Share on other sites

OK. Are you devices visible in your Windows Device Manager?  If so can you look up the PID and VID hardware properties (in Device Manager advanced)?

Share this post


Link to post
Share on other sites

Sorry missed your post somehow. im struggling to find my device listed as its a no name infra red overlay touchscreen from China. 


Okay I found it. Now to try and find Pid Vid.


Port_#0003.Hub_#0003

 

hidcorrect_zps399a84a8.png

Share this post


Link to post
Share on other sites

Hi Zoran

 

The PID and VID can be viewed by opening the Device Manager and looking under Human Interface Devices. Find the device that is not being recognised by LINDA and  open the properties (double click or right click and select properties). Then under Details, select Hardware Ids from the Property dropdown.  The Vendor and Product IDs (VID/PID) appear in the first and second line as a 4 character hexadecimal number.

 

The VID and PID are used by LINDA to work out the type of device and whether it should be included in the list of devices.

 

 

DeviceManagerAll%20copy.jpg

Share this post


Link to post
Share on other sites

Okay there are 3 HID compliant sections under the touchscreen. 

 

hidfinal_zps6a4778d7.png

 

 

1. HID compliant device

 

HID\VID_04B4&PID_C001&REV_1001&Col04

HID\VID_04B4&PID_C001&Col04

 

2. HID compliant device

 

HID\VID_04B4&PID_C001&REV_1001&Col01

HID\VID_04B4&PID_C001&Col01

 

3. HID compliant mouse

 

HID\VID_04B4&PID_C001&REV_1001&Col03

HID\VID_04B4&PID_C001&Col03

Share this post


Link to post
Share on other sites

Hi angeli662

 

So I can investigate please follow procedure above and report the VID and PID on the device that is reporting the error.

Share this post


Link to post
Share on other sites

Hi angeli662

 

So I can investigate please follow procedure above and report the VID and PID on the device that is reporting the error.

Scot thanks for the reply, this what I found out, I have a game keyboard from RAZER (SWOTOR)

which has a lcd touch pad with a driver from Synaptics  which I have disable I lost  that functionality of the keyboard and now I can see 6 of my 7 FSX hardware except the

GF-RP48 Push Button Rotary from Goflight, the throttle though is showing with all the axis and buttons. is there anything I can do? I have just stumble into LINDA 2 days ago and very excited to learn it.

 

Thanks in advance.

 

Rick

gysKU.jpg

Share this post


Link to post
Share on other sites

Rick, go to control panel, hardware and devices and your GF-RP48 Push Button Rotary should be in there. From there you can right click and go to the details tab and to the property drop down list and then to Hardware Id's

Share this post


Link to post
Share on other sites

Thanks Zoran, It happens to be there all the time and there are 2 entries for my keyboard too. I just renamed it and all good except my keyboard partially working. It is going to be hard to chose.JsZFj.jpg

Share this post


Link to post
Share on other sites

Hi Rick

 

Can you look at #8 above and let me have the VID and PID for the Razer gaming keyboard that is causing the fault report?

Share this post


Link to post
Share on other sites

Hi Scot, here what I have:

 

 

Synaptics
USB\VID_1532&PID_002B&REV_0100&MI_00
USB\VID_1532&PID_002B&MI_00
 
SWOTOR 1
USB\VID_1532&PID_002B&REV_0100&MI_01
USB\VID_1532&PID_002B&MI_01
 
SWOTOR 2
USB\VID_1532&PID_002B&MI_01&JS_12
 
SWOTOR 3
USB\VID_1532&PID_002B&REV_0100&MI_01
USB\VID_1532&PID_002B&MI_01
 
LINDA GUI
 
8 and 9 Joysticks/HID controllers
 
1532002B1 - SWTOR Keyboard  → Axes: 0  Buttons: 1  Hats: 0
1532002B2 - SWTOR Keyboard  → Axes: 0  Buttons: 1  Hats: 0
 
I have 4 drivers  for this devices, if I disable the Synaptics LINDA wors fine.
Q1Do.jpg

This is what it look like :P 7Cbep.jpg

Share this post


Link to post
Share on other sites

Thanks Rick

 

That is very useful. The Synaptics looks like it is the touch pad on your keyboard which is incorrectly being identified as a one-button HID.  All I need to do now is hunt down where the problem is in the code I inherited.

 

A couple of questions. At what point does the Error Dialog appear and what appears in the Console?

Share this post


Link to post
Share on other sites

Hi Scot,  If I have the Synaptics driver enable the error occurs as I try to open LINDA, although it does open all the others disappears. the error is presented with a window "Device can not be opened"  just like the first poster. nothing appears in the console as  there are no hardware recognized.

But I will double check just in case.

Let me know if you need anything else.

 

thanks so much

 

Rick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this