Jump to content

Sign in to follow this  
MrSpeaker

problem with all my pmdg aircraft

Recommended Posts

Guys I am hoping maybe someone can help me. This all seem to happen after the last update of gsx. If I load a pmdg aircraft. Nothing in the fsx addon menu is selectable. My asn will not connect. My trakir will not work. And my ch yoke and saitek throtle will not function. If I remove the fsuipc dll from my fsx intall everything works again. I have reinstalled simconnect. Fsuipc. My c ++ runtimes and removed all fsdt stuff. No joy. If it's a pmdg aircraft with fsuipc enabled nothing works. Any help. Been struggling with this for a week.

Share this post


Link to post
Share on other sites

I wonder if your dll.xml has become corrupt.  That seems to me to be the only file that links all the addons you have mentioned.  You can find it at C:\Users\UserName\AppData\Roaming\Microsoft\FSX.  There should be a few backup dll.xml's in that location for you to compare to.

Share this post


Link to post
Share on other sites

Thanks Robert, I will check that out too see if I notice anything. I recall a xml editor, not sure if its here in the library or not.

Share this post


Link to post
Share on other sites

Whilst there was no apparent defect in the dll.xml format restoring a backup as suggested by Robert fixed similar issues here.

Share this post


Link to post
Share on other sites

Thanks guys, no joy, same issue, used an old dll.xml did not work, made a new one with a nifty tool from flight1 did not work, loaded a default aircraft first and it did not work either. Been using fsuipc with pmdg  right from 06 and have never seen this issue. Its obvious a problem with fsuipc but Pete is away. Anyways if anyone else has any idea's  please let me know. totally stumped on this one.

Share this post


Link to post
Share on other sites

Sorry to hear Ian.  Have you run the latest FSDT Addon Manager?  That may fix the issue:

 

http://www.fsdreamteam.com/products_addonmanager.html

 

You could uninstall GSX and it should replace the existing dll.xml with a backup that it made.  Failing that you should head over and post at the FSDT forum, maybe Umberto can help you.  

Share this post


Link to post
Share on other sites

Sorry to hear Ian.  Have you run the latest FSDT Addon Manager?  That may fix the issue:

 

http://www.fsdreamteam.com/products_addonmanager.html

 

You could uninstall GSX and it should replace the existing dll.xml with a backup that it made.  Failing that you should head over and post at the FSDT forum, maybe Umberto can help you.  

Oh boy after days of scouring the fsuipc forum I found the issue, a corrupted wxstationlist.bin file, Deleted it and everything is fine, that was so nasty.Thanks everyone for the suggestions, that was a real bugger to figure out.

Share this post


Link to post
Share on other sites

Glad that you found the issue Ian, wonder how the .BIN was corrupted.  Good work on finding the solution.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...