Sign in to follow this  
gpbarth

Aivlasoft's EFB & FSX SE

Recommended Posts

I was running EFB very well with FSX, until I had a system problem that required me to uninstall FSX completely. I re-installed with FSX SE, and began to re-install all of my prior FSX apps. Haven't had any problems, until I got to Aivlasoft's EFB.  I cannot get the data provider to run...it installed and did it's initial construction, and at the end it crashed. The reason I'm posting up here is that the Aivlasoft forum seems to be putting the onus of solving the problem on other users - a typical reply from the Aivlasoft crew says (in effect), "Why don't you look up the error and see what's wrong?" It seems that they have no idea how to deal with this.

 

Anyway, here is my post from their forum and the error I keep getting:

 

I completely removed FSX and all of its components and re-installed FSX SE. I was running EFB on two computers (both running Win7/64), and all was running fine. Now, however, the data provider will not install - it looks good and runs through all of its paces, but at the end, ir crashes, with the enclosed message. Since I am running Win7, the docs say that I am already running .Net framework 3.5, so I don't think that's the problem, but here's the rest of the data from the box:
 

************** Exception Text **************
System.IO.FileNotFoundException: The specified module could not be found. (Exception from HRESULT: 0x8007007E)
at bh.c(Object A_0, EventArgs A_1)
at System.Windows.Forms.Timer.OnTick(EventArgs e)
at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5477 (Win7SP1GDR.050727-5400)

----------------------------------------
AivlaSoft.Efb.DataProvider
Assembly Version: 1.5.1.15704
Win32 Version: 1.5.1.0

----------------------------------------
log4net
Assembly Version: 1.2.10.0
Win32 Version: 1.2.10.0

----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5468 (Win7SP1GDR.050727-5400)

----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5467 (Win7SP1GDR.050727-5400)

----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5467 (Win7SP1GDR.050727-5400)

----------------------------------------
DevExpress.Utils.v9.1
Assembly Version: 9.1.4.0
Win32 Version: 9.1.4.0

----------------------------------------
Rhino.Commons
Assembly Version: 2.0.0.0
Win32 Version: 2.0.0.1414

----------------------------------------
Castle.Windsor
Assembly Version: 1.0.3.0
Win32 Version: 1.0.3.5114

----------------------------------------
Castle.Core
Assembly Version: 1.0.3.0
Win32 Version: 1.0.3.5114

----------------------------------------
Castle.MicroKernel
Assembly Version: 1.0.3.0
Win32 Version: 1.0.3.5114

----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5476 (Win7SP1GDR.050727-5400)

----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5476 (Win7SP1GDR.050727-5400)

----------------------------------------
Rhino.Commons.Clr
Assembly Version: 2.0.0.0
Win32 Version: 2.0.0.1414

----------------------------------------
System.Web
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)

----------------------------------------
Castle.DynamicProxy2
Assembly Version: 2.0.3.0
Win32 Version: 2.0.3.5114

----------------------------------------
AivlaSoft.Efb.Common
Assembly Version: 1.5.1.15699
Win32 Version: 1.5.1.0

----------------------------------------
System.Core
Assembly Version: 3.5.0.0
Win32 Version: 3.5.30729.5420 built by: Win7SP1

----------------------------------------
DevExpress.Data.v9.1
Assembly Version: 9.1.4.0
Win32 Version: 9.1.4.0

----------------------------------------
DevExpress.XtraEditors.v9.1
Assembly Version: 9.1.4.0
Win32 Version: 9.1.4.0

----------------------------------------
System.Data
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)

----------------------------------------
DevExpress.XtraGrid.v9.1
Assembly Version: 9.1.4.0
Win32 Version: 9.1.4.0

----------------------------------------
DevExpress.XtraBars.v9.1
Assembly Version: 9.1.4.0
Win32 Version: 9.1.4.0

----------------------------------------
Desaware.MachineLicense35
Assembly Version: 1.6.0.0
Win32 Version: 1.6.3.0

----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.5420 (Win7SP1.050727-5400)

----------------------------------------
Desaware.Dls.Interfaces20
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0

----------------------------------------
System.Security
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5475 (Win7SP1GDR.050727-5400)

----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
************************************************************************************

I'd love to get this working. Any help would be greatly appreciated.
 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I completely removed FSX and all of its components and re-installed FSX SE

So have you checked to see that -SE is installed as FSX would have?

 

For example, you can check the correct folders exist, e.g. "C:\Users\<you>\Documents\Flight Simulator X - Steam Edition Files" will not do, should be "C:\Users\<you>\Documents\Flight Simulator X Files".

 

In the registry: "HKEY_CURRENT_USER\Software\Microsoft\Microsoft Games\Flight Simulator - Steam Edition\Co-Existence=1" also will not do, should be =0.

 

 

Folders need to be the same as boxed FSX, except for Program Files where the -SE version installs its program files:

 

C:\Program Files (x86)\Steam\steamapps\common\FSX

C:\ProgramData\Microsoft\FSX

C:\Users\<you>\AppData\Local\Microsoft\FSX

C:\Users\<you>\AppData\Roaming\Microsoft\FSX

cfg:

C:\Users\<you>\AppData\Roaming\Microsoft\FSX\fsx.CFG

documents:

C:\Users\<you>\Documents\Flight Simulator X Files

pics:

C:\Users\<you>\Pictures\Flight Simulator X Files

Share this post


Link to post
Share on other sites

Try installing the legacy SimConnect modules, found in the Steam FSX SDK folder under Core Utilities.

 

Pete

Share this post


Link to post
Share on other sites

To install Data Provider EFB looks for installed fsx.

Data Provider needs to be installed on same pc where fsx is installed.

 

EFB does not see fsx steam. 

 

I have the same problem. 

Waiting for update EFB

Share this post


Link to post
Share on other sites

To install Data Provider EFB looks for installed fsx.

Data Provider needs to be installed on same pc where fsx is installed.

 

EFB does not see fsx steam. 

 

I have the same problem. 

Waiting for update EFB

 

Seems to work fine here -- you do need to have the FSX SimConnect installed.

 

It doesn't appear to need to "see" FSX-SE, it links to it via SimConnect. Maybe the problem is only its access to the NavData?  That's normally stored in your FSX\Aivlasoft folder. It should be able to find it in the Steam FSX folder too, for an FSX-SE only install, otherwise it would find it still in the FSX folders.

 

Pete

Share this post


Link to post
Share on other sites

Although FSX simconnect is left on the system and should remain working when FSX is uninstalled, there may be some problem with it. As Pete suggests, could try running the legacy simconnect installers just in case:

 

..\SteamApps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-RTM\SimConnect.msi

..\SteamApps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-SP1\SimConnect.msi

..\SteamApps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-XPACK\SimConnect.msi

 

Those having installed FSX-SE on a fresh Windows PC (not seen FSX) should at least run the SP1 and XPACK installers.

Share this post


Link to post
Share on other sites

Thank you very much, Pete & Steve. Installing those SimConnects did the trick. While I hate to bad-mouth developers, it seems that the guys over at AivlaSoft had no idea what was wrong.  In almost a week, there was no response or suggestions on what to do. But when I turned to AvSim and you guys, it was an over-night fix!

 

Now I have to go back over there and tell them how to fix their own problem.

 

Again, thanks a whole bunch!

Share this post


Link to post
Share on other sites

Hello everybody,

 

I'm running on the same PC FSX & FSX:SE. It works well and I had no problem to launch my networked EFB. Everything seems OK with Aerosoft Airbus X and PMDG 777 SP1d. EFB on ground is OK too. But when I take off with this aircrafts, a few minutes pass and suddenly FSX:SE crashes!

 

Without EFB I can complete a normal flight. Did you get the same trouble? Any ideas?

 

Skip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this