Sign in to follow this  
chiozza

Start Engines

Recommended Posts

When I make the call the FO to start the engines, they call out "oil pressure" but the engines do not start up.What am I doing wrong?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


When I make the call the FO to start the engines, they call out "oil pressure" but the engines do not start up.What am I doing wrong?

 

Are you running the before start procedures?

 

Is the aircraft configured properly for engine start?

Share this post


Link to post
Share on other sites

As far as I understand it, as the Captain, after the FO indicates oil pressure, you have to then switch the Fuel cut off switch for whatever engine you are trying to start to enable fuel flow, the engine should then spool up.

Share this post


Link to post
Share on other sites

 

 


after the FO indicates oil pressure, you have to then switch the Fuel cut off switch

 

Actually the Captain (you) would set the fuel lever to idle detent around 20 percent N2 generally speaking.

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this