Sign in to follow this  
TristanAbyss

Flight1 Gtn 750 for Dummies in v2.4

Recommended Posts

Dear Simmers,

 

I purchased the Flight1 GTN750 for my GA Aircrafts in v2.4. I installed the GTN750 from F1 and I installed the Garmin Light Trainer as requested. I ran the F1 GTN config program and all seemed well. But in each plane I tested, even if it has a genuine install option for the GTN750 like the Realair Turbine Duke, or not (e.g. Carenado Seneca, Carenado Phenom, Epic Victory...) the GTN750 Panel remains black. The instrument itself is visible, even intergrated in the panels or as popup, the knobs are turnable, but the "touchdown screen" remains black...  And yes, the Avionics is on.

 

Anyone able to help me, what I did wrong?

 

Sorry for my incompetence....

:blush:

 

Tris

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Go to their forum and they will work with you to figure it out!

 

Cheers

Martin

Share this post


Link to post

I'm fairly sure the newer versions of their gauge don't work with anything older than P3D version 2.5

 

This is most likely the problem if the F1GTN is a clean install.

Share this post


Link to post

Is your antivirus switched off. I had a problem when I installed it at the weekend. I had to go into each module and add the GTN 750. I've only installed it on the Duke and the A2A 182.

 

Very nice piece of kit.

Share this post


Link to post

Dear Matt,

 

to which modules exactly do you have to add it manually?

 

In addition I learned on the forums, that the first time you loaded an aircraft with the GTN a window opens, where you have to direct to the path, where the Garmin Trainer Lite is. Such windows never opens with me. Maybe that is the problem. But where to direct than to the correct path?

 

Tris

Share this post


Link to post
Hello,

 

guess what: I solved the problem myself!

It was connected with the Windows firewall. I deinstalled F1GTN and GTN trainer, and deleted all remaining files and folders, than I switched off my firewall completely.

I redownloaded the GTN750 and the trainer and reinstalled all with the firewall off. Afterward I switched the firewall on again and tried the GTN.

And now it works!!

Nevertheless I just want to thank the F1 support team for their quick responses and provided help. There are not much providers with such exceptional customer service!

 

my best regards,

 

Tris

Share this post


Link to post

Hi Tris,

 

sorry I missed your first post, but looks like you sorted your problem. It's a very good piece of kit, and I'm only using it with the A2A's 182 and the Real Air Duke.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this