Sign in to follow this  
hazbenz

FSInn Issue

Recommended Posts

Hi All,
I have a wee problem with FSInn. It appears that it cannot connect to anything. When I start FSInnUI the Control Panel pops up as per normal. What is not normal is that the FSInn button and the mCP button at the top of the Control Panel are RED. Also no Servers (Vatsim, Net2, 3, 4 or FSFDT) are shown on the left side of the Control Panel. I am running Win7 x64 (new install, all updates installed), Prepar3d (2.5.19245.0), Estonia Migration Tool (downloaded yesterday), NO Antivirus, NO anti-spyware. This PC is specifically for Flight Simming.

 

It runs behind a Untangle firewall which has not been changed since I ran FSInn with FSX Acceleration successfully.

 

I have followed (to the letter) the instructions here (http://board.flightsim.ee/discussion/446/fsinn-don039t-work-with-p3dv2-5-12944-0) and checked against these here (http://forums.vatsim.net/viewtopic.php?f=43&t=47063).

 

I have added FSInnUI.exe to Windows Firewall Exception and also tried running with the Firewall turned off.

 

Nothing seems to be working. I don't believe this is an issue with P3D but I think it is a communication/firewall issue.

 

I would really appreciate any assistance at this point

 

Cheers

 

Harry
 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Harry

 

A good way to test is to turn off firewall and antivirus temporarily and see if FSInn works, if it does, then make sure that all executable files (*.exe) under the FSFDT folder have exclusions in your antivirus software and in your firewall. The server addresses that are default in FSInn are not working anymore. You'll need to obtain the latest IP addresses from Vatsim or if you have Vatspy from the servers tab.

Share this post


Link to post

Hi Joaquin,

Forgot to mention that this PC has no Antivirus and that I have tried turning off the Firewall (Windows Firewall).  I also have a second drive with FSX Acceleration installed.  This is a separate Windows installation and boot drive in the same physical PC that has my P3D 2.5 installation.  I fired that up and tested FSInn and it worked.  I could connect to Vatsim and the two other Flight servers that I use.

 

So that now leads me to believe that there is nothing wrong with my Untangle firewall configuration (on a separate PC and on my network edge as it should be) or my internal network configuration (I have a 5 PC and  SBS2011 server internal network).

 

I now come to the conclusion that the only difference IS P3D.  And the only discernible difference between the FSX and P3D installs is that the FSFDT install did not add the menu item to the Addon Menu in P3D.  I have checked that the dll.xml file has the Fscopilot.dll entry and that this is the last entry in the dll.xml file.

 

 

FSFDT is installed in the root of C:\ (C:\FSFDT) and P3D is also installed in the root of C:\ (C:\Prepar3d v2).

 

I am now at the end of my knowledge of possible fixes.

 

Cheers

 

Harry

Share this post


Link to post

OK, I think I have confirmed that this is definitely a P3D issue. I uninstalled FSInn and FScopilot. I then changed the Ownership security on the P3D folder to Administrators group from System. Reinstalled FSFDT and started P3D from the Estonia Migration Tool in Legacy Mode. Checked the Addons Menu and FSFDT was present. Fired up FSInn (NOT from the Addons menu) and it worked!! Unfortunately, only the once :angry:. Subsequent starts in Legacy and "Normal" Virtual Mode have not had the Menu entry reappear and FSInn will NOT connect without it.

 

Any chance anyone has any ideas how to get this working??

 

Cheers

 

Harry

Share this post


Link to post

In P3D the only way to get FSInn to run is with the Migration Tool enabled. At least this is the only way I have managed to get it to work. Check your dll.cfg file to make sure there is an entry for FSCopilot. If the entry is missing that is the reason why you cannot see anything in the pull down menu. Add the entry manually if necessary and it should work OK. 

Share this post


Link to post

Not really an answer, but I found vPilot to be much easier to use

Share this post


Link to post

Hi Joaquin,

Yeah, I have EMT running. The entry is in the dll.xml file and I have moved it to the bottom of the file as suggested in several posts - unfortunately still no luck. When I uninstalled and reinstalled I went through the registry to find any trace of FSFDT, FScopilot and FSInn and deleted any reference. I also went through and hunted down every file I could find that was related.

 

Hi Chris

Unfortunately Vatsim is not the only place I fly. I also fly with Hovercontrol (though not for a wee while but must get back there soon) and Tasman (who use the VBNav server). Hence the need for FSInn.

Share this post


Link to post

Reading back to your earlier post you wrote:

 

"Subsequent starts in Legacy and "Normal" Virtual Mode have not had the Menu entry reappear and FSInn will NOT connect without it."

 

What do you mean by Legacy & Normal mode. My P3D doesn't have 2 different start modes, or at least I am not aware of them.

 

Regards

Share this post


Link to post

Hi Joaquin,

Legacy and "Normal" Mode are options in the Migration Tool. Essentially Legacy mode fires up from the FSX.exe file in your P3D install and "Normal" fires up the normal P3D.exe.

 

Cheers

 

Harry

Share this post


Link to post

Harry

 

I'll check my settings this evening and will get back to you.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this