Sign in to follow this  
Luis Cortez

Saitek X-55, switches moving without input?

Recommended Posts

Hey everyone!

 

I was wondering if anyone else with the X-55 HOTAS system had this problem. I set my flaps to SW1-2, and landing gear on SW5-6. But randomly, in FS the gear and flaps will come down/up in flight, or on the ground at random as if someone hit the switches without any user input. 

 

I calibrate through FSUIPC, and I notice when I want to assign commands to buttons/switches, it seems as if switches and buttons are randomly being pushed on their own erratically and I don't have time to assign a command because another switch toggles randomly. 

 

Does anyone have a remedy to this issue? Thank you so much!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Please don't get upset at simple questions, like I get when I am looking for my car keys and my wife suggests looking in the "key drawer", which of course is the first place I looked.... LOL

 

Have you tried plugging into a different USB port?  Also, you might investigate (Google) Saitek device issues with Windows Advanced Power Management, though the characteristic of those issues are more often associated with Windows 8.X and Windows 10, and evidenced by the device going dark and cold (non-responsive).

Share this post


Link to post
Share on other sites

Did you disable the joystick input in the options to make sure that no other buttons are causing the issue?

Share this post


Link to post
Share on other sites

Is it plugged into a USB hub? If so does the hub have its own power source? the X55 is a power hungry device that does not like to share USB power!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this