Sign in to follow this  
Bina

Turning-off Saitek X52 Pro instead of unplugging it

Recommended Posts

Hi guys,

 

The title says it all actually. Is it really possible?!

 

Just to expand the issue a little bit: I always use FSUIPC for axis control and button assignments instead of native FSX controller support. And in order to allow FSUIPC take "full control" of my joystick, I do uncheck "Enable Controller(s)" tickbox in FSX menu before loading the flight, as also advised in FSUIPC User Guide. However, from what I read on more than a dozen of FS-related forum pages and actually experienced on my own system (JOYSTICKS=0 under [CONTROLS] section of the FSX.CFG helps only if the joystick remains plugged in), unplugging the joystick from a USB slot (which I usually do after each FSX session to save on energy consumption and joystick operating life. Above all, the LEDs are irritating when the stick is not in use!) and restarting a new FSX session makes FSX to assume that the joystick has been changed and it (actually, the OS) assigns a different GUID to the re-plugged joystick.

 

I've tried the advice on deactivating "USB selective suspend setting" under the Windows' Power Options menu to no avail, unfortunately. Therefore, the only possible option seems to be turning off the controller instead of simply unplugging it. But how can I achieve that, if ever possible?

 

Thanks!

 

PS: My operating system is Windows 7 x64 with FSX Acceleration installed.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Go into Windows Control Panel, to Device Manager, look under Human Interface Devices and try to identify the Saitek X52. If it is not clearly identified in the list, which will also contain multiple lines for your keyboard and mouse, then you may have to experiment by unplugging the X52 and determining which line went away. Then if that is needed plug it back in and wait for that line to show up again.

 

Then right click on the X52 entry and disable it. You will have to remember to return to Device Manager and enable it before the next time you want to use it.

Share this post


Link to post
Share on other sites

Alternatively, go to the FSUIPC user guide that is in your modules/FSUIPC Documents folder, and seach for "Keeping track of multiple control devices". Follow the instructions there and your computer (or rather FSUIPC) will never lose track of your controllers again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this