Sign in to follow this  
SO666

Logitech G430 Headset Problems

Recommended Posts

Hi.

I am having problems with my recently purcased logitech g430 headset , i can only get the sounds working in surround sound for about 15 mins in FSX , before it corrupts the sounds, also i can get it setup in vpilot easy enough , and gives excellent sounds , but comms with atc can suddenly stop working without warning , and in TS3 i get an echo that is imposible to stop .

If anyone has this headset and got it fully working reliably with FSX/ASN/VPILOT/TS3 , could you please let me know how you have the settings , and the driver you are useing , so i can see where i am going wrong .

Also are you using it plugged in directly using the jacks or with the supplied usb adaptor .

I have tried everything i can think off to get it working without success sofar , i submitted a ticket with logitech , but they have been usless with their response .

regards alan cottrill.

SO666.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I realize that we aren't supposed to discuss hardware in this forum but there isn't a category in the hardware section that discusses headsets. Also, FSX is referenced along with some addons. I believe the OP will get an answer here faster than any other forum.

 

If you can help this fellow simmer, please do so.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this