Sign in to follow this  
jcomm

Problems with REX Soft Clouds...

Recommended Posts

Maybe someone already came across an identical situation and can provide some help... I have already opened a thread at the REX site forum too...

 

Yesterday I tried to re-install REX Soft Clouds in my rig.

 

The installer gave no error, but when I start the application I get a black screen in my User Interface window and can't do nothing. Clicking on it I get the typical "your application has stopped working.... " error.

 

I have uninstalled Rex Soft and the associated MS DB stuff it also installs, and repeated the install process with no success :-(

 

Any ideas ?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

A long shot Jose,  but have you tried the little things, Like proper permission rights on your application also i take it you have gone into Compatibility  and are Running as Administrator.  I also add everything into my Exclusions Zone of my Anit virus Software 

 

Long shot,  you never know though 

Share this post


Link to post
Share on other sites

Thx Elaine,

 

I did take all of those measures into account though :-/ but with no success...

 

The only thing that differs from the last time I had it installed was that I applied the November win 10 update, but I haven't had problems with any other app - just Rex Soft Clouds...

 

Well, I'll keep trying to find a solution, and if and when I find it, I will post it in this thread :-)

Share this post


Link to post
Share on other sites

Elaine,

 

as promised, I found the solution at an MS SQL support blog here:

 

http://www.skimedic.com/blog/post/2013/12/23/Fixing-SQL-Server-Express-Local-DB-for-Visual-Studio.aspx

 

Applied all steps and it worked beautifully, so, I am tempted to believe that what caused the problem was probably the Win 10 November 11 upgrade ( ? ) but I am not absolutely sure...

 

Anyway, Rex Soft Clouds now works :-)

 

Just in case the above link dies, here's the transcription of the content:

 

LocalDB is a (fairly) new, stripped down version of SQL Express 2012.  It doesn’t require a service, so it can be deployed much easier along with your Visual Studio project.  It’s a great alternative for applications that don’t need all of the power of SQL Server, and where you don’t have control over the target machine to ensure that SQL Express is installed.  In fact, many of the samples available from Microsoft use LocalDB. Are you using LocalDB?  It’s easy to check.  If your connection string starts with “(LocalDB)\v11.0”, indeed you are.
 
Sounds great, doesn’t it?  Except when LocalDB doesn’t work.  I ran into this issue on my main development machine.  I tried reinstalling LocalDB (there is a separate install on the SQL Server Express download page), uninstalled SQL Express and reinstalled, you know, all of the usual tricks.  No luck.
 
 
To sum it up, open a command window (preferably running as administrator), and navigate to where the LocalDB general instances are kept (%localappdata%\Microsoft\Microsoft SQL Server Local DB\Instances\v11.0), and type:
 
>sqllocaldb create "v11.0"
 
If you receive an error similar to this:
"Creation of LocalDB instance "v11.0" with version 11.0 failed because of the following error: 
LocalDB instance is corrupted. See the Windows Application event log for event details." 
Your LocalDb needs to be deleted and re-created.  Fortunately, it’s easy. Enter these commands:
 
>sqllocaldb delete "v11.0" 
Response whould be similar to “LocalDB instance "v11.0" deleted. \”
 
Once you’ve cleaned out the corrupted instance, re-create it:
 
>sqllocaldb create "v11.0" 
LocalDB instance "v11.0" created with version 11.0 
 
And that’s it!  You should be able to fully take advantage of LocalDb in your projects now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this