Sign in to follow this  
YukonPete

Activating problems P3D v 2.5

Recommended Posts

Anyone else always have problems activating? When ever I try and activate 2.5 online I get an error that says my licence could not be found on the server. I contact LM support and the just reply that I must enter the wrong license. But I never have this problem with P3Dv3! I even confirmed my license with them. And then when I try the email activation it generates a different set of codes each time I start it so the activation codes will only work if I leave my PC on. Like I said I never have this problem with v3.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Having a little grief with my installed V3 [activated] I installed and activated 2.5 fine around an hour or so ago.  Regards.

Share this post


Link to post

Pete, might sound silly but i had some issues myself activating 2.5 in the past.  It turned out i was mixing my Customer ID up with my Licence ID  :smile:

Share this post


Link to post

Pete, might sound silly but i had some issues myself activating 2.5 in the past.  It turned out i was mixing my Customer ID up with my Licence ID  :smile:

  No I am not mixing it up. I have triple checked! :(

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this