Sign in to follow this  
Rockliffe

2 sticks of RAM or 4

Recommended Posts

I have been running my system for the best part of 4 years now, most of the time without any problem. Asus P8Z68-V MB, i5 2500K OC @ 4.6ghz, MSI GTX770 4Gb GPU. However, for some reason that remains a mystery, I have been encountering a lot of BSODs recently. Nothing has changed, apart from the removal of 4 x 2gb sticks of RAM, with 2 x 8gb sticks. This was done to accommodate some video editing that I now need to use on the PC.

 

I was always told that the 4 sticks are necessary so as to split across the 4 channels of the CPU (?) When i questioned the PC guy who looks after my machine, he said that it was not an issue and 2 sticks was just fine. He seemed quite adamant about his position on the subject. Is he right, or should I have 4 sticks of RAM?

 

I can't think of any other reason why I am suddenly getting BSODs. It may be some duff RAM but I'd be interested in hearing from some of the whizz guys on here. Cheers.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have been running my system for the best part of 4 years now, most of the time without any problem. Asus P8Z68-V MB, i5 2500K OC @ 4.6ghz, MSI GTX770 4Gb GPU. However, for some reason that remains a mystery, I have been encountering a lot of BSODs recently. Nothing has changed, apart from the removal of 4 x 2gb sticks of RAM, with 2 x 8gb sticks. This was done to accommodate some video editing that I now need to use on the PC.

 

I was always told that the 4 sticks are necessary so as to split across the 4 channels of the CPU (?) When i questioned the PC guy who looks after my machine, he said that it was not an issue and 2 sticks was just fine. He seemed quite adamant about his position on the subject. Is he right, or should I have 4 sticks of RAM?

 

I can't think of any other reason why I am suddenly getting BSODs. It may be some duff RAM but I'd be interested in hearing from some of the whizz guys on here. Cheers.

 

The 2500K has two channels, so you can max that out with only two RAM sticks, but you have to make sure the sticks are installed in the proper slots.

The number of memory channels don't do much if anything at all for performance.

 

As for the BSODs, if you are using the same OC profile with the new set of RAM sticks, that may very well be the problem.

 

How did you overclock the system?

Have you overclocked the memory too?

Share this post


Link to post
Share on other sites

The 2500K has two channels, so you can max that out with only two RAM sticks, but you have to make sure the sticks are installed in the proper slots.

The number of memory channels don't do much if anything at all for performance.

 

As for the BSODs, if you are using the same OC profile with the new set of RAM sticks, that may very well be the problem.

 

How did you overclock the system?

Have you overclocked the memory too?

 

Hi Dazz, thanks for the reply. Hmm, OK. Sure, it's the same OC profile, as nothing was changed after replacing the RAM. Well, as for the overclock, I bought the machine pre OC from UK Overclockers. As I said, it's been as stable as a lead weight since buying it. It's only after installing the RAM that the issue has appeared. Any advice?

Share this post


Link to post
Share on other sites

Please post captures of the latest version of CPU-Z's SPD & Memory tabs, 

Share this post


Link to post
Share on other sites

 Here ya go...

 

Slots are good, but those sticks seem to run at some unusual timings. Notice you're running them at 1600MHz 9-9-9-28-2T (mobo defaults) but we can't tell from those JEDEC's at what timings they're designed to run at 1600MHz.

 

Apparently there's no XMP profile unfortunatelly, so you probably need to go to the BIOS and dial in all the timings manually.

 

You have three options:

 

1. Check if there's indeed an XMP profile in your BIOS

 

2. Go for the sticks' rated speed and timings. 

 

3. Be conservative and leave the memory clock at 800MHz (1600Mhz) and set the timings at something like 11-11-10-29-40-2T

 

Are you comfortable doing that in your BIOS?

Share this post


Link to post
Share on other sites

Hi Folks,

 

While it won't help with your BSOD issue - just upgraded my PC this weekend from 8GB@1600 x2 to 16GB@2133 x2 using an XMP profile - - - while I haven't run any real performance tests everything seems a bit snappier (placebo effect ?)... I have a similar processor as well - 2700K @ 4.5 GHz... Don't thinks the 2 memory bank usage would be an issue...

 

Regards,

Scott

Share this post


Link to post
Share on other sites

Slots are good, but those sticks seem to run at some unusual timings. Notice you're running them at 1600MHz 9-9-9-28-2T (mobo defaults) but we can't tell from those JEDEC's at what timings they're designed to run at 1600MHz.

 

Apparently there's no XMP profile unfortunatelly, so you probably need to go to the BIOS and dial in all the timings manually.

 

You have three options:

 

1. Check if there's indeed an XMP profile in your BIOS

 

2. Go for the sticks' rated speed and timings. 

 

3. Be conservative and leave the memory clock at 800MHz (1600Mhz) and set the timings at something like 11-11-10-29-40-2T

 

Are you comfortable doing that in your BIOS?

 

Hi matey, hmm, sorry you don't want to here this, but I haven't got a clue! I'm not completely a nonk, but unsure what. 1) Don't know how to do 2) Where will I find the sticks' rated speeds? 3) Where do I set the timings in the BIOS?  

Share this post


Link to post
Share on other sites

Hi Howard,

 

I think you need to get the manufacturer/model number of the installed memory so you can look up the speed ??? As far as I understand it - if your motherboard supports XMP it's just an option under something like advanced memory management - I believe XMP is just a profile so you don't have to manage all the timings yourself... When I selected XMP profile 1 - I noticed my displayed speed changed from 1600 to 2133... First time I've ever messed with memory settings so I could certainly have a gross conceptual error on what I did - so take it with a grain of salt... Hope it helps...

 

Regards,

Scott

Share this post


Link to post
Share on other sites

Hi Howard,

 

I think you need to get the manufacturer/model number of the installed memory so you can look up the speed ??? As far as I understand it - if your motherboard supports XMP it's just an option under something like advanced memory management - I believe the XMP is just a profile so you don't have to manage all the timings yourself... When I selected XMP profile 1 - I noticed my displayed speed changed from 1600 to 2133... First time I've ever messed with memory settings so I could certainly have a gross conceptual error on what I did - so take it with a grain of salt... Hope it helps...

 

Regards,

Scott

 

Hi Scott, thanks matey. I will have to find the timings of the RAM. Where in CPUz is this shown, any idea? iS THIS THE SAME AS LATENCY? I thought the speed of the ram was 1600Mhz but I can't see anything that shows anything close to that figure.

Share this post


Link to post
Share on other sites
Try the XMP profile first:

 

1. Restart your system

2. After it beeps, press DEL repeatedly until the BIOS shows up

3. Click "Advanced Mode" on the top-right corner

4. Click the "AI-Tweaker" tab

5. Locate the "AI Overclock Tuner" option, click the button to it's right (should read "Manual", mine reads "Auto" here)

 

how1.jpg

 

6. Select "X.M.P." if available. If it's not there, then you need to input your timings manually

7. You should see a new option bellow with the selected XMP profile. Here's mine:

 

how2.jpg

 

8. Click "Exit" on the top right corner

9. Click "Save changes and restart"

Share this post


Link to post
Share on other sites

 

Try the XMP profile first:
 
1. Restart your system
2. After it beeps, press DEL repeatedly until the BIOS shows up
3. Click "Advanced Mode" on the top-right corner
4. Click the "AI-Tweaker" tab
5. Locate the "AI Overclock Tuner" option, click the button to it's right (should read "Manual", mine reads "Auto" here)
 
 
 
6. Select "X.M.P." if available. If it's not there, then you need to input your timings manually
7. You should see a new option bellow with the selected XMP profile. Here's mine:
 
8. Click "Exit" on the top right corner
9. Click "Save changes and restart"

 

 

Thanks for the help with this Dazz, but I don't seem to have anything that refers to XMP...

 

bios.jpg

 

 

 

 

Is this where I input the ram timings? If so, where will I find the ram timings? 

 

bios2.jpg

Share this post


Link to post
Share on other sites

Thanks for the help with this Dazz, but I don't seem to have anything that refers to XMP...

You need to press the button that reads "Manual" to the right of "AI Overclock Tuner"

 

Howbios.jpg

 

A pop up window should appear with 3 options: Auto, Manual and X.M.P.

Select X.M.P.

If the X.M.P. option is not there, then you need to dial in all the timings manually at "DRAM Timing Control" further down in that same screen

Share this post


Link to post
Share on other sites

You need to press the button that reads "Manual" to the right of "AI Overclock Tuner"

A pop up window should appear with 3 options: Auto, Manual and X.M.P.

Select X.M.P.

If the X.M.P. option is not there, then you need to dial in all the timings manually at "DRAM Timing Control" further down in that same screen

 

 

OK, only manual and auto appear So where do I find the timings Dazz?  From CPUz?

Share this post


Link to post
Share on other sites

Yes, but in your case, none of the JEDECs in CPU-Z is your actual rated speed. But I would just play it safe and select this:

 

 

Is this the kit yo have there? http://media.kingston.com/pdfs/HyperX_FURY_EN.pdf

 

OK, those same readings shown above, ie 9,9,9,28 are showing up in the memory tab of CPUz. They are the same that appear in the BIOS timing control. Are they pertinent or should I still change the values to what you suggest?   Yes, that's exactly the RAM I have.

Share this post


Link to post
Share on other sites

OK, those same readings shown above, ie 9,9,9,28 are showing up in the memory tab of CPUz. They are the same that appear in the BIOS timing control. Are they pertinent or should I still change the values to what you suggest?

 

The values in the "Memory" tab in CPU-Z are the ones in that BIOS page, the ones you probably need to change. Make it 11-11-10-30-2 instead of 11-11-10-29-2

Share this post


Link to post
Share on other sites

The values in the "Memory" tab in CPU-Z are the ones in that BIOS page, the ones you probably need to change. Make it 11-11-10-30-2 instead of 11-11-10-29-2

 

I'm a little confused,  I'll follow your suggestion. May I ask what is the purpose of changing the values from the values that match CPUz?

Share this post


Link to post
Share on other sites

I'm a little confused, where are the values that you are suggesting? I know where to change them in BIOS but are they not supposed to show in CPUz? 

 

The values you are supposed to use are the ones the RAM is rated to. Those timings vary with speed, so they need to be looser the fastest the RAM runs. JEDECs shown here are the manufacturer's speed/timing these sticks are rated to

 

slot2.jpg

 

Problem is none of those JEDECs  is for 800MHz, which is the speed you're currently running your RAM at, so we can't know based on that what the proper timings for 800MHz are. I picked the timings for a faster JEDEC (888MHz) to play it safe. Higher timings mean less stress to the memory controller so what we are doing here is "downclocking" the memory to release some stress from the CPU/IMC

Share this post


Link to post
Share on other sites

The values you are supposed to use are the ones the RAM is rated to. Those timings vary with speed, so they need to be looser the fastest the RAM runs. JEDECs shown here are the manufacturer's speed/timing these sticks are rated to

 

slot2.jpg

 

Problem is none of those JEDECs  is for 800MHz, which is the speed you're currently running your RAM at, so we can't know based on that what the proper timings for 800MHz are. I picked the timings for a faster JEDEC (888MHz) to play it safe. Higher timings mean less stress to the memory controller so what we are doing here is "downclocking" the memory to release some stress from the CPU/IMC

 

 

Ahhh, I see. Well thanks very much for your help with this Dazz, it's very much appreciated. I'll wait to see if I get any further BSODs. If we don't chat soon, have a good Christmas, cheers.

Share this post


Link to post
Share on other sites

If the BSOD continues we can look into adding some voltage or dropping the clock down from 4.6 to 4.5 just to verify stability. So dont worry there are more options to try and get rid of the blue screens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this