Sign in to follow this  
urgeflaske

Saitek X52 Pro doesnt work.. anymore

Recommended Posts

Hi!

 

I have the x52 Pro and had it for a long time. Last time i used it was under a year ago and it worked fine without any problems. So when i recently purchased a new plane for P3D i wanted to use my joystick again. Now the leds on the throttle doesnt work, the screen doesnt work either. Well the screen works, but i cant push any buttons to start/stop the time etc. I tried to install the saitek driver but the setup just freeze. If i try to shut down my computer with the joystick plugged in it will freeze on the "logging off.." screen. If i start my computer with the joystick plugged in it freezes on the log-on screen and i have to unplug joystick and restart the computer.

 

Is there anything i can do with this problem or is the joystick broken?

 

Oh, btw. I tried it 1 week ago and it worked fine except the leds on the throttle not working. Didnt install any drivers then, but it worked in P3D without any.

 

Aaand im running Windows 7 64-bit.

 

 

Edit: The green power led on the throttle is green when plugged in and the leds works fine on the joystick itself (not on the throttle).

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Same problem.  During installation the unit comes on with the lights.  However, the driver installation doesnt complete and is stuck indefinitely.  I have no choice but to force shut the setup.  After this the joystick and the throttle seem to be working but the computer freezes at the logging off screen and when the computer is restarted with the joystick plugged in, the computer freezes on the log on screen and the joystick has to be unplugged and the system has to be restarted.

 

I dont think the joystick is broken.

 

Would also appreciate if someone guides me on how to uninstall the drivers completely.

 

Ted

Share this post


Link to post
Share on other sites

Hi, I had a similar problem months ago and my solution was to uninstall the drivers, to use a cleaning utility to make sure there were no drivers letfovers and reinstall the same drivers again (that I had downloaded time ago from the Saitek website). Hope this help.

Cheers,

Edward

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this